Náhradní hardware vázaný na technologii Windows Autopilot
概要: Následující článek vám ukáže, jak opravit problémy s doménou technologie Windows Autopilot po výměně dílů nebo počítače. To platí pro počítače se systémem Windows 10 a Windows 11.
現象
Hardware zaregistrovaný pomocí technologie Windows Autopilot
Došlo v poslední době k výměně základní desky nebo výměně počítače? Obdrželi jste jednotku, která se nepřihlásí k vašemu nájemci Entra Identification (ID) (dříve Azure Active Directory (AAD))? Je počítač zaregistrován do jiné domény Entra ID? Zobrazí se výzva k zadání přihlašovacích údajů, ale je uveden nesprávný název domény Entra ID.
原因
Opravený počítač zkontroluje připojení k internetu při procházení prostředím po prvním zapnutí (OOBE). ID základní desky se zkontroluje v cloudu Autopilot. Pokusí se automaticky připojit k tomuto nájemci Entra ID, pokud najde organizaci, u které je zaregistrovaná. Následující příklad používá obecný název testovacího nájemce společnosti Microsoft.

Jedná se o problém celého ekosystému, kdy se klíčové komponenty základní desky používají k identifikaci zařízení v cloudu Microsoft. Organizace se může vzdát kontroly nad zařízením nebo základní deskou, ale nezruší registraci zařízení před jeho vrácením nebo servisem. Pokud k tomu dojde, společnost Microsoft zachová přidružení k původnímu nájemci služby Entra ID a poté zobrazí přihlašovací obrazovku dané organizace.
解決方法
Společnost Dell investuje do dvou řešení, která tento problém řeší. Skládají se z následujících prvků:
- Společnost Dell běžně ruší registraci identity Autopilot přidružené k zařízení, pokud byla v rámci záruční opravy vyměněna základní deska tohoto zařízení. Tím se zabrání tomu, aby vrácená základní deska blokovala jakékoli jiné zařízení při repasování a opětovném použití.
- Společnost Dell umožnila svým týmům podpory reagovat a pomoci, pokud se na ně obrátíte v případě zablokování základní desky. To zachytí zařízení, která se vyhnou prvnímu prvku.
Tyto prvky mohou zrušit registraci základních desek nainstalovaných ve výrobě. Společnost Microsoft však doporučuje následující postup pro zařízení zaregistrovaná v systému Autopilot po opravě pomocí hardwarového hashe. Společnost Microsoft jej musí zrušit.
Jedná se konkrétně o problém společnosti Dell?
Ne, systém Autopilot má stejný vliv na všechny výrobce originálního vybavení (OEM). Cesta řešení již není pro všechny výrobce zařízení stejná. Žádost o zrušení registrace musíte odeslat prostřednictvím portálu Intune, aby společnost Microsoft mohla zrušit registraci starší identity Autopilot.
| OEM | Databáze znalostí | Shrnutí |
|---|---|---|
| HP | Komerční notebooky, stolní počítače a mobilní pracovní stanice HP – systém Microsoft Windows uvádí přihlášení k jiné společnosti |
Obraťte se na podporu společnosti Microsoft a požádejte o zrušení registrace zařízení. |
| Lenovo | Microsoft Windows Autopilot: Často kladené dotazy a příručka k odstraňování problémů |
Chcete-li získat podporu, odešlete případ společnosti Microsoft pomocí smlouvy Microsoft Volume Licensing Center. |
| ASUS | Registrace služby ASUS pro Windows Autopilot |
Co společnosti Dell a Microsoft dělají, aby tento problém vyřešily?
Společnost Dell během vývoje těchto nových funkcí komunikovala se společností Microsoft. Řešení popsaná v tomto článku však platí pouze pro produkty Dell. Společnost Dell i nadále úzce spolupracuje se společností Microsoft na zlepšování svých možností. Společnost Dell poskytuje zpětnou vazbu k revizím technologie Autopilot od společnosti Microsoft s cílem zabránit opakování tohoto problému. (Někdy se označuje jako Autopilot v2.)
Automatická náprava
Od listopadu 2022 společnost Dell nepodporuje automatickou opětovnou registraci zařízení Autopilot po výměně základní desky:
Problémy, se kterými se společnost Microsoft při tomto procesu setkala, však omezily určitou funkčnost.
Ruční registrace:
Při pokusu o nahrání hashe hardwaru se zobrazí chyba.
Error 806 - ZtdDeviceAlreadyAssigned
- Zařízení ve vašem nájemci již existuje.
- Odstraňte objekt zařízení ze služby Intune (Device Enrollment -> Windows Enrollment -> Windows Autopilot Devices) a kliknutím na tlačítko Sync urychlete synchronizaci s obchodem Windows Store pro firmy.
Error 808 - ZtdDeviceAssignedToOtherTenant
Když se zařízení po výměně základní desky přihlásí do portálu Intune, zkontroluje se hodnota hashe hardwaru. Tento hash odráží hardware opraveného zařízení a liší se od hodnoty před opravou. Systém Autopilot rozpozná hash, pokud jej jiný zákazník zaregistroval ve svém nájemci. Tato registrace nebyla zrušena a chybu generuje pokus o registraci.
Vymazání vyžaduje ruční zrušení registrace staršího registračního záznamu v databázi Microsoft Autopilot. Vzhledem k opatřením, která společnost Dell zavedla, by se mělo jednat o ojedinělý jev. Pokud se s tím setkáte, pro pomoc se obraťte na technickou podporu společnosti Dell:
Mohou se vyskytnout i další chyby:
“This feature is not supported. Contact your system administrator with the error code 80180014”
K této chybě dochází, když se pokusíte zaregistrovat zařízení, které systém Autopilot považuje za osobní zařízení. Správce ale nakonfiguroval zásadu omezení registrace zařízení, která brání registraci osobních zařízení.
Tato chybová zpráva se zobrazí na zařízení, u kterého byla nedávna vyměněna základní deska. K chybě dojde, pokud zapomenete nahrát podnikový identifikátor nebo aktualizovaný hash hardwaru zařízení, abyste systému Autopilot sdělili, že se jedná o zařízení vlastněné společností. Podnikové identifikátory je možné používat s přípravou zařízení Autopilot. Příprava zařízení Autopilot a podnikové identifikátory jsou součástí přepracování technologie Windows Autopilot od Microsoftu. (Někdy se označuje jako Autopilot v2.) Pokud používáte Windows Autopilot pro předem zřízená zařízení, musíte nahrát hash hardwaru pomocí Intune. (Dříve Autopilot White Glove.)
- Identifikace zařízení jako firemních
- Zjištění ID (4K) nového zařízení Autopilot pro zákazníka
- Přehled přípravy zařízení Windows Autopilot
Může nám společnost Dell zaslat další základní desku?
Společnost Dell předpokládá, že díky kombinaci řešení, která jsou nyní k dispozici, je tento postup zbytečný.
Může společnost Dell zrušit mou registraci za mě? (Bez použití portálu Intune?)
Týmy podpory společnosti Dell mají přístup k portálu pro registraci zařízení, u nichž byla základní deska vyměněna v rámci záruky. Pokud potřebujete další pomoc, kontaktujte nás pomocí informací uvedených na následujícím odkazu:
Společnost Dell také běžně ruší registraci identity Autopilot u zařízení, u kterých byla základní deska vyměněna v rámci záruky.
Co mám dělat, když společnost Dell nemůže zrušit mou registraci?
Obraťte se na technickou podporu společnosti Microsoft přímo prostřednictvím portálu podpory nebo chatu. Společnost Microsoft vyžaduje ke zrušení registrace zařízení jeho identifikátory a doklad o zakoupení. Získejte kopii faktury:
-
Získejte kopii faktury za počítač z historie objednávek společnosti Dell:
-
Klikněte na možnost Sign In (Přihlásit se).
-
Zadejte e-mailovou adresu a heslo k účtu Dell.
-
Klikněte na možnost Zobrazit historii objednávek.
-
Vyberte objednávku pro svůj počítač.
-
Uložte si kopii faktury do složky Dokumenty.
-
Pojmenujte fakturu:
invoice.pdf
-
Zahajte relaci podpory u společnosti Microsoft:
-
Můžete použít následující odkaz:
-
Přihlaste se ke svému účtu Microsoft (MSA).
-
Klikněte na ikonu Windows a vyberte možnost Home Support.
-
Zadáním
Autopilot device deregistrationdo pole popisu problému. -
Klikněte na možnost Get Help.
-
Klikněte na možnost Contact Support v dolní části stránky.
-
Vyberte kategorii produktu a podpory:
-
Windows
-
technická podpora
-
-
Klikněte na tlačítko Confirm.
-
Klikněte na možnost Chat with a support agent.
-
Nahrajte kopii faktury a klikněte na tlačítko Confirm.
-
Otevře se relace chatu.
Jakmile se vás pracovník podpory zeptá na popis problému, zkopírujte a vložte následující podrobnosti. My device had a motherboard replacement. I need Microsoft to deregister the device from Intune. (Entra ID or Azure.) Pokud vás zástupce společnosti Microsoft požádá o doklad o nákupu a informace o zařízení, podívejte se na dokument, který jste nahráli před otevřením relace chatu. Můžete být požádáni o vygenerování hashe hardwaru ze zařízení, který v prostředí při prvním zapnutí zobrazuje nesprávného nájemce nebo doménu. Zajistěte, abyste měli během relace chatu přístup k tomuto počítači.
Jak zrušit registraci počítače, aby nedošlo k tomuto problému?
Postupujte podle pokynů společnosti Microsoft ke zrušení registrace zařízení ze systému Autopilot prostřednictvím konzole Intune. Následujícím postupem odeberete zařízení z konzole Intune, odeberete objekt Entra ID a zrušíte jeho registraci v systému Autopilot.
Můžete zrušit registraci jakéhokoli počítače registrovaného v systému Autopilot ve svém nájemci pomocí konzole Intune. To lze provést bez ohledu na to, zda výrobce OEM nebo poskytovatel cloudových služeb společnosti Microsoft (například prodejce) zařízení zaregistrovali. Společnost Microsoft pracuje na tom, aby výrobci OEM mohli snáze rušit registraci počítačů, které vyrobili. Toto zrušení registrace však odstraní pouze registraci v systému Autopilot. Nedojde ke zrušení registrace zařízení z portálu Intune ani k odebrání objektu zařízení ze služby Entra ID, takže budete muset odstranit osamocené záznamy.
Po opravě počítače se tyto záznamy vytvoří znovu. To lze provést tak, že zaregistrujete zařízení pomocí hardwarového hashe a pomocí technologie Autopilot zaregistrujete zařízení s jeho novou identitou.
Jak registrovat tuto novou základní desku pro použití s technologií Windows Autopilot?
Postupujte podle pokynů společnosti Microsoft a zaregistrujte opravenou desku pro vaše zařízení se správnou identitou prostřednictvím konzole Intune. Tento proces vyžaduje obnovení operačního systému a zaznamenání hashe hardwaru pomocí skriptu PowerShell. Záruční technici společnosti Dell pro vás nemohou zaznamenat hash hardwaru.
Registrace prostřednictvím hashe hardwaru se v tomto případě nejlépe provádí importem hashe hardwaru prostřednictvím vaší konzole Intune.
その他の情報
Doporučené články
Zde je několik doporučených článků týkajících se tohoto tématu, které by vás mohly zajímat:
- Článek znalostní databáze Dell: Windows Autopilot – Příprava počítače na servis
- Článek znalostní databáze Dell: Windows Autopilot – pozvání společnosti Dell coby partnera OEM