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Windowsデバッガーを使用してブルー スクリーンをトラブルシューティングする方法

概要: Windowsデバッガー(WinDbg)をダウンロードして実行し、ミニダンプ ファイルを読み取り、Windowsオペレーティング システムのブルー スクリーン エラーをトラブルシューティングする方法について説明します。

この記事は自動翻訳されたものである可能性があります。品質に関するフィードバックがある場合は、このページの下部にあるフォームを使用してお知らせください。

文書の内容


現象

コンピューターでブルー スクリーンが発生した場合、何が起こったかを確認し、問題を修正して、再発を防ぐにはどうすればよいでしょうか。この状況では、メモリー ダンプ ファイルが役に立つ場合があります。メモリー ダンプ ファイルには、コンピューターにブルー スクリーンが発生した原因を特定するのに役立つ、最小限の有益な情報が含まれています。Windowsデバッガー(WinDbgとも呼ばれる)は、ブルー スクリーン ミニダンプのトラブルシューティングに役立つMicrosoft製のツールです。Windowsデバッガーは、ミニダンプ ファイルの読み取りに役立つツールです。

メモリー ダンプ ファイルには、次の情報が含まれています。

  • 停止メッセージ、そのパラメーター、その他のデータ
  • ロードされたドライバーのリスト
  • 停止したプロセッサーのプロセッサー コンテキスト(PRCB)
  • 停止したプロセスのプロセス情報とカーネル コンテキスト(EPROCESS)
  • 停止したプロセスのプロセス情報とカーネル コンテキスト(ETHREAD)
  • 停止したスレッドのカーネルモードのコール スタック

対象オペレーティング システム:

  • Windows 11
  • Windows 10

原因

ブルー スクリーン エラーの原因はさまざまです。ハードウェアの故障の場合もあれば、ソフトウェアの破損の場合もあります。

解決方法

Windowsデバッガーを使用するには、WinDbg Previewをインストールして実行し、ダンプ ファイルを分析してから、分析結果をレビューします。また、ドライバー検証ツールを使用して情報を収集することもできます。詳細については、該当するタイトルをクリックしてください。

インストールと実行

  1. Microsoft Storeで「WinDbg」を検索し、WinDbg Previewをダウンロードします。

WinDbg Previewのダウンロード
図1: WinDbg Previewのダウンロード

  1. アプリケーションをインストールしたら、Windowsの検索からWinDbg Previewを開きます。

WinDbgを開く
図2:WinDbgを開く

ダンプ ファイルの分析

  1. ファイル]メニューをクリックします。
  2. Settings]をクリックし、[Debugging settings]をクリックして、[Default symbol path]を見つけます。[Default symbol path]に、「srv*https://msdl.microsoft.com/download/symbols」と入力し、[OK]をクリックします。

[Default symbol path]の設定
図3:[Default symbol path]の設定

注:シンボル パスの詳細については、「Windowsデバッガーのシンボル パス このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。」を参照してください。
  1. File]、[Open source file]、[Open dump file]の順にクリックします。ここから、ダンプ ファイルを参照し、[Open]をクリックします。

ダンプ ファイルを開く
図4:ダンプ ファイルを開く

注:アプリケーションのクラッシュ ダンプ ファイルとWindowsのダンプ ファイルは、[Dump File]の適切な場所に移動した後に分析できます。例えば、ダンプ ファイルを確認する一般的な場所は次の2つです。
  • C:\Users\XYZ\AppData\Local\CrashDumps\
  • C:\Windows\Minidump\
  1. ファイルを分析するには、「!analyze -v」と入力して、Enterを押します。

analyzeコマンドの実行
図5:analyzeコマンドの実行

  1. 分析が完了すると、Windowsデバッガーにブルー スクリーンの原因となっているファイルが表示されます。ファイルの分析結果の MODULE_NAME または IMAGE_NAME を確認します。結果のレビューは、さらなるトラブルシューティング手順に役立ち、エラーの原因の究明につながります。

分析のレビュー
図6:分析のレビュー

分析結果のレビュー

エラーの詳細については、『バグ チェック コード リファレンスこのハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』の「バグ チェック コード」を参照してください。

ブルー スクリーン エラー コードの確認リンクの詳細については、『停止エラーまたはブルー スクリーン エラーの高度なトラブルシューティングこのハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

ファイル情報の詳細については、『Process Explorer v17.05このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

ブルー スクリーンの解決方法の詳細については、『Windows のブルー スクリーン エラーの解決このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

Windowsデバッガーの詳細については、『WinDbg を使用してカーネル モード ダンプ ファイルを分析するこのハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

analyze拡張機能の詳細については、『!analyze 拡張機能の使用このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』と『!analyze (WinDbg)このハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

ドライバー検証ツールを使用した情報の収集

ブルー スクリーン エラーの約75%は、ドライバーの問題が原因で発生します。ドライバー検証ツールは、インストールされているドライバーの動作を確認するためにリアルタイムで実行されます。Driver Verifier ManagerはWindowsに組み込まれており、すべてのWindowsコンピューターで使用できます。

Driver Verifier Managerを起動するには、次の手順を実行します。

  1. タスクバーの[検索]をクリックし、フィールドに「CMD」と入力します。
  2. 「コマンド プロンプト」を右クリックし、「管理者として実行」を選択します。
  3. コマンド プロンプトに、「Verifier」と入力します。

検証したいドライバーを指定することができます。検証ツールは、実行中に検証対象のドライバーに関連付けられているすべてのドライバーを追加します。そのため、できるだけ少ない数のドライバーを検証するようにしてください。詳細については、『ドライバーの検証ツールこのハイパーリンクをクリックすると、デル・テクノロジーズ以外のWebサイトにアクセスします。』を参照してください。

その他の情報

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文書のプロパティ


影響を受ける製品

Operating Systems

最後に公開された日付

08 3月 2024

バージョン

8

文書の種類

Solution