PowerStore:PowerStoreに移行した後、Windows VMが起動時にStopコード0xC000021Aでクラッシュする
概要: 別のストレージ アレイからPowerStoreにVMを移行すると、起動時にブルー スクリーンが発生する場合があります。移行後にVMを再起動すると、STOPコード0xC000021Aでブルー スクリーンが表示される可能性がありますが、他のSTOPコードの可能性もあります。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
UEFI起動を使用しているVMは、起動中にブルー スクリーンになります。
この問題は、パッチが適用されていないバージョンのESXiで発生します。VMwareのKB 2137402を参照してください。
これは次の場合に適用されます。
この問題は、PowerStoreログで「WRITE with size exceeding MAX TRANSFER」を検索することで、特定できます。
この問題は、パッチが適用されていないバージョンのESXiで発生します。VMwareのKB 2137402を参照してください。
これは次の場合に適用されます。
- ESXiバージョン6.5、6.7、7.0
- Windows Server 2012、2016、2019 VM
- VMFS5またはVMFS6
- ライブ移行またはコールド移行
この問題は、PowerStoreログで「WRITE with size exceeding MAX TRANSFER」を検索することで、特定できます。
The error displayed is "parse_error_full:364: WRITE with size exceeding MAX TRANSFER SIZE (2056 >= 2048)":
または、次のような行の数をカウントします。
svc_journalctl | grep "WRITE with size exceeding MAX TRANSFER" | wc -l 1131348
原因
ホストはPowerStoreのベスト プラクティスに従って設定されていません。
https://dl.dell.com/content/manual37523884-dell-emc-powerstore-host-configuration-guide.pdf
特に、次の推奨設定値のセクションを参照してください。
Disk.DiskMaxIOSize = 1024
ここではESXiでの既知の問題が公開されており、これらは最新バージョンで解決されます。
解決方法
ESXiホストで次のコマンドを実行して、現在の値を確認します。
PowerStoreの場合、Int Valueは1024に設定する必要があります。
各ESXiホストで次のコマンドを実行して、正しい値を設定します。
esxcli system settings advanced list -o "/Disk/DiskMaxIOSize"
PowerStoreの場合、Int Valueは1024に設定する必要があります。
Path: /Disk/DiskMaxIOSize Type: integer Int Value: 1024 Default Int Value: 32767 Min Value: 32 Max Value: 32767 String Value: Default String Value: Valid Characters: Description: Max Disk READ/WRITE I/O size before splitting (in KB)
各ESXiホストで次のコマンドを実行して、正しい値を設定します。
esxcli system settings advanced set -o "/Disk/DiskMaxIOSize" --int-value 1024
その他の情報
KB 000182665は、同じ問題について説明していますが、症状は異なります。
対象製品
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000T製品
PowerStore 9000X文書のプロパティ
文書番号: 000196159
文書の種類: Solution
最終更新: 14 12月 2022
バージョン: 7
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。