「PowerStore:VASAプロバイダーがダウンしている間に何が発生しますか?

概要: VMware vSphereでは、vVolアーキテクチャは、ストレージ環境とvSphere環境の間でコントロール プレーンとデータ プレーンを利用します。これらは、VASA(vStorage APIs for Storage Awareness)を使用して通信します。 ソフトウェア アップグレードなどの一部のPowerStoreストレージ操作では、ストレージ操作の実行中に、VASAプロバイダーがロックされ、コントロール プレーンのVASAコマンドが一時的に一時停止されます。 ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

PowerStore VASA Providerが一時停止すると、vSphere UIには、ローカル(PowerStore-X)VVolデータストアがアクセス不可として表示されるか、ホストされているVVolデータストア(PowerStore-TまたはPowerStore-X)がアクセス不可として表示されます。  これは、vSphereからPowerStore VASAコントロール プレーンへの通信が一時停止された場合に発生します。  vSphere UI VASA情報が古く、 (inaccessible)と表示されます。

VASAプロバイダーを使用しているvVolには、UIからアクセスできません。データは影響を受けないデータ プレーンを使用しています。  これは懸念事項ですが、実際の問題を確認せずに対処すべきではありません
image_1.png

手記:PowerStore VASAプロバイダーが説明されている状態の場合、一部のvSphere操作は制限されます。

  • VMの作成
  • VMのクローン作成
  • VMの電源をオンにします。
  • VMの電源をオフにします。
  • VMをシャットダウンします。
  • 同じPowerStore上の別のSCへのStorage vMotion
  • コンピューティングvMotion
  • VMを削除します。
  • スナップショットの作成
一部のお客様にとって、vSphere UIにアクセスできないステータス、またはこのようなVM操作を実行できないことは、中断を招いていると見なされる場合があります。

一部の操作は、次のようなvCenterエラーで失敗する場合があります。モジュール モニター電源投入のループに失敗しました。仮想マシンの起動に失敗しました。

VASAプロバイダーにアクセスできない、またはオフラインの間は、ゲスト内の制限を含め、その他の操作もサポートされない場合があります。

原因

VASAプロバイダーは、ネットワーク、vCenter、PowerStoreの問題などのさまざまな原因で、またはコードのアップグレードなどのストレージ操作中に、アクセス不能またはオフラインになる可能性があります。これは、データが使用不可であることを意味しているわけではなく、IOは引き続き処理でき、VMは引き続き実行されています。

解決方法

PowerStore OSバージョン3.0(またはそれ以降のバージョン)では、フェールオーバーと起動の時間を改善および短縮することで、VASAのダウンタイムが最小限に抑えられました

この問題が発生した場合は、ESXiホストまたはPowerStoreノードを再起動しないでください

VASAステータスを確認する方法

vSphere UIの使用

vCenter Serverに移動し>>ストレージ プロバイダーを構成して、PowerStore VASAプロバイダーを見つけます。

  • ステータスがオンラインになっている必要があります

image_2.png

ESXiコマンド ラインの使用

  • ESXiホストにSSHで接続します。
  • esxcli storage vvol vasaprovider listコマンドを実行します。
  • ステータスが[Online]である必要があります

image-2022-09-22-11-50-04-228.png

PowerStoreグローバル サポートに連絡するタイミングを教えてください。

  • vVolベースのVMにデータ プレーンの中断が発生した場合
  • VASAコントロール プレーンは、一定時間が経過しても自動リカバリーされません。
    • これは、数千のvVolsを使用する環境では、5〜10分から30〜60+分まで、使用状況によって異なります。

その他の情報

対象製品

PowerStore
文書のプロパティ
文書番号: 000205326
文書の種類: Solution
最終更新: 08 9月 2025
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。