「VxRail:スケジュール設定されたVxRailバックアップ タスクが「NoneType」で失敗しました。オブジェクトに属性「replace」がありません
概要: VxRail Managerのバックアップ タスクのスケジュール設定がエラー「NoneType」で失敗しました。オブジェクトに属性「replace」がありません。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
現時点では、この問題はVxRailバージョン7.0.350で発生しています。解決策はこのバージョンにのみ適用されます
インチ VxRailBackupRestore.logファイルに置き換えます。
VxM_Backup & Restore: 2022-12-01 01:29:04,743 - INFO cronjob is updated. VxM_Backup & Restore: 2022-12-01 01:29:04,822 - ERROR Caused: 'NoneType' object has no attribute 'replace' VxM_Backup & Restore: 2022-12-01 01:29:04,822 - ERROR [VxM Backup & Restore ABNORMAL END] VxM_Backup & Restore: 2022-12-01 01:29:15,314 - INFO Starting to get authentication info. VxM_Backup & Restore: 2022-12-01 01:29:15,336 - INFO Connecting to vCenter [VC FQDN] VxM_Backup & Restore: 2022-12-01 01:29:15,422 - ERROR Caused: 'NoneType' object has no attribute 'replace' VxM_Backup & Restore: 2022-12-01 01:29:15,423 - ERROR [VxM Backup & Restore ABNORMAL END] VxM_Backup & Restore: 2022-12-01 01:30:06,398 - INFO Starting to get authentication info. VxM_Backup & Restore: 2022-12-01 01:30:06,420 - INFO Connecting to vCenter [VC FQDN] VxM_Backup & Restore: 2022-12-01 01:30:06,494 - ERROR Caused: 'NoneType' object has no attribute 'replace' VxM_Backup & Restore: 2022-12-01 01:30:06,495 - ERROR [VxM Backup & Restore ABNORMAL END]
バックアップ ジョブを手動で実行する場合:
原因
VSANデータストア オブジェクトIDを取得する際のコードの欠陥。
解決方法
スクリプトを変更する /mystic/vxm_backup_restore/common.py 次のように、さらに 2 行を追加します
メモ:変更には注意し、インデントとしてスペースを使用してください。
def get_primary_datastore(cluster_obj):
"""Get the primary datastore on the specified cluster"""
if not cluster_obj:
return None
if not cluster_obj.datastore:
return None
current_vxm_sn = get_vxm_sn()
for datastore in cluster_obj.datastore:
if not datastore.vm:
continue
for vm in datastore.vm:
if vm.summary.config.uuid is None: # new added
continue # new added
vm_uuid = vm.summary.config.uuid.replace("-", "")
if vm_uuid in current_vxm_sn:
return datastore
return None対象製品
VxRail文書のプロパティ
文書番号: 000206764
文書の種類: Solution
最終更新: 24 2月 2026
バージョン: 2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。