NetWorker: AD/LDAP entegrasyonu HTTP hatası 400 ile başarısız oluyor, ortam SSL olmayan kimlik doğrulamayı desteklemez (LDAP: hata kodu 8 - 00002028: LdapErr: DSID-0C090276)

概要: NetWorker'a AD kimlik doğrulaması ekleme girişimi HTTP hatası 400 (Bozuk İstek) ile başarısız oluyor

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Authentication Authority Provider creation failed!

Unable to add external authentication provider to authentication service [ ErrorMsg: POST failed with HTTP-ERROR: 400. Server Message: Could not parse server-response from json string, HTTPErrorCode: 400]
  • Harici kimlik doğrulaması eklemek için kullanılan yapılandırma değerlerde herhangi bir sorun görünmüyor. 
  • AUTHC hata ayıklamayı etkinleştirmek, authc-server.log dosyasında aşağıdaki mesajı bildirir:
YYYY-MM-DDTHH:MM:SS DEBUG Resolved [com.emc.brs.auth.server.exception.LdapVerifyException: The verification of the configuration options for Ldap has failed. [ LDAP: error code 8 - 00002028: LdapErr: DSID-0C090276, comment: The server requires binds to turn on integrity checking if SSL\TLS are not already active on the connection, data 0, v2580 ]; nested exception is javax.naming.AuthenticationNotSupportedException
NOT: authc-server.log dosyası, hata ayıklama etkinleştirilmeden güncelleştirilmezse.
 

原因

LDAP sunucusu üzerinde, SSL ile güvenli hale gelen tüm LDAP kimlik doğrulamalarını zorleyen varsayılan olmayan bir güvenlik ayarı vardır. 

Etki alanı denetleyicisindeki bu ilke şu şekildedir: "Etki alanı denetleyicisi: LDAP sunucu imzalama gereksinimleri" ve "İmzalama gerekli" olarak ayarlandığında, SSL kullanmak üzere yapılandırılmamışsa bağlantılar başarısız olur.

LDAP sunucusu imzalı iletişim gerektiren şekilde yapılandırıldığından basit bağlama talepleri (bağlantı noktası 389) LDAP sunucusu tarafından reddedilir.

解決方法

対象製品

NetWorker

製品

NetWorker Family, NetWorker Series
文書のプロパティ
文書番号: 000207700
文書の種類: Solution
最終更新: 25 3月 2025
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。