ADユーザーを使用してログインしたときにPowerProtect DD Management CenterでData Domainを管理できない

概要: ADユーザーを使用してDDMCにログインすると、DDMCでDDを管理できません。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

 PowerProtect DD Management Center(DDMC)UIエラーは次のように報告されます。
"Failed to get data center list" java.lang.NullPointerException

ddms.info ログ レポート:
Java.lang.NullPointerException: null
        at  com.datadomain.ddmc.server.rest.api.dto.SystemDerivedAccessDto.convertFromUserRole(SystemDerivedAccessDto.java:11) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.api.dto.GsSystemDto.setUserRole(GsSystemDto.java:202) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.api.dataCenter.SystemUtils.addRoleAndDerivedAccess(SystemUtils.java:56) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.api.dataCenter.SystemUtils.fillAdditionalDetails(SystemUtils.java:36) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.api.dataCenter.DataCenterAPI.fillSystemInfo(DataCenterAPI.java:156) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.api.dataCenter.DataCenterAPI.getDataCenters(DataCenterAPI.java:130) ~[server.jar:?]
        at com.datadomain.ddmc.server.rest.resource.DataCenterResource.getDataCenters(DataCenterResource.java:88) ~[server.jar:?]
        at sun.reflect.GeneratedMethodAccessor629.invoke(Unknown Source) ~[?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_261]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_261]

sms.info ログは次の情報を返します。 
02/03 12:37:44.504338 [7f5a0df20310] updates_systems_get_job: User a-riggsrx@oneabbott.com does not have 'admin|limited-admin|user' role on system EDLAP14C011.oneabbott.com
02/03 12:37:44.504392 [7f5a0df20310] updates_systems_get_job: User a-riggsrx@oneabbott.com does not have 'admin|limited-admin|user' role on system EDLRP21011.oneabbott.com
02/03 12:37:44.504947 [7f5a0df20310] completed web-service request: 7041 for service: rest_updates_systems_1_resource_get, duration: 154 msec, status: OK

原因

UIはAPIを呼び出して、各管理対象システム上のADユーザーのロールを解決します。このAPIは、userRole(admin/limited-admin、userなど)ではなくNULLを返します。このため、UIでは、ADユーザーがページを表示する権限を持っていない可能性があり、何も表示されない可能性があります。

解決方法

修正はDDMC 7.11リリースで行われます。
文書のプロパティ
文書番号: 000208274
文書の種類: Solution
最終更新: 03 5月 2023
バージョン:  2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。