NetWorker:NMC UIの「Unable to launch application」および「Unsigned application requesting unrestricted access to system」エラー

概要: NetWorker Management Console (NMC)を起動すると、「Unable to launch application」エラーでUIの起動に失敗します。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • NetWorker Management Console (NMC)を起動すると、「Unable to launch application」エラーでユーザー インターフェイスの起動に失敗します。
「Unable to launch the application」メッセージ
  • [Details]タブには、次のエラーが報告されます。
Error: システム
への無制限のアクセスを要求する未署名のアプリケーション 署名されていないリソース https://< NMCサーバー>:9000/LGTOnmc/java/comtsk.jar
  Java - [More Information]

原因

Java 8 Update 131リリース以降、MD5withRSAまたはMD5withDSAアルゴリズムで署名されたアプリケーションは、署名されていないものとして扱われます。

解決方法

1.NREインストール セキュリティ パスの下にあるjava.securityファイルを編集します。
NREの場合、ファイルへのフル パスは C:\Program Files\NRE\java\<jre version>\lib\security\java.securityです。

2.次の例のように、「jdk.jar」で始まる行をコメント アウトします。
 
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
#     DSA keySize < 1024, include jdk.disabled.namedCurves
3.変更を保存します。
4.NMC UIを起動します。

対象製品

NetWorker, NetWorker Management Console

製品

NetWorker Family, NetWorker Series
文書のプロパティ
文書番号: 000210820
文書の種類: Solution
最終更新: 28 5月 2023
バージョン:  2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。