NetWorker:NMC UI 「無法啟動應用程式」,未簽署的應用程式要求不受限制的系統存取
概要: 啟動 NetWorker Management Console (NMC) 時,UI 無法啟動,並顯示「無法啟動應用程式」錯誤。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
- 啟動 NetWorker Management Console (NMC) 時,使用者介面無法啟動,並顯示「無法啟動應用程式」。
- “詳細資訊”選項卡報告以下錯誤:
Error: 要求不受限制存取系統的
未簽署應用程式 https://< NMC 伺服器>的未簽署資源:9000/LGTOnmc/java/comtsk.jar
未簽署應用程式 https://< NMC 伺服器>的未簽署資源:9000/LGTOnmc/java/comtsk.jar
原因
從 Java 8 Update 131 版本開始,使用 MD5withRSA 或 MD5withDSA 演算法簽署的應用程式會被視為未簽署。
解決方法
1.編輯 NRE 安裝安全性路徑下的 java.security 檔案。
若為 NRE,檔案的完整路徑為 C:\Program Files\NRE\java\<jre version>\lib\security\java.security。
2.註釋掉以「jdk.jar」開頭的行,如下例所示-
4.啟動 NMC UI。
若為 NRE,檔案的完整路徑為 C:\Program Files\NRE\java\<jre version>\lib\security\java.security。
2.註釋掉以「jdk.jar」開頭的行,如下例所示-
# jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024, \
# DSA keySize < 1024, include jdk.disabled.namedCurves 3.儲存變更。
4.啟動 NMC UI。
対象製品
NetWorker, NetWorker Management Console製品
NetWorker Family, NetWorker Series文書のプロパティ
文書番号: 000210820
文書の種類: Solution
最終更新: 28 5月 2023
バージョン: 2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。