「VxRail:CloudIQでDYNAMIC_NODEクラスターの最終連絡日が正しく報告されない問題を解決する方法
概要: 7.0.400+でCloudIQがDYNAMIC_NODEクラスターの[Last Contact]日を正しくレポートしない問題を解決する方法。
この記事は次に適用されます:
この記事は次には適用されません:
この記事は、特定の製品に関連付けられていません。
すべての製品パージョンがこの記事に記載されているわけではありません。
現象
クラスターはDYNAMIC_NODE.
ですVxRailバージョンは7.0.400+.
ですADCが1.5.306(修正を含む将来のリリース)未満
CIQの最終到着日が更新されていません。
原因
7.0.400+でクラスター タグが「COMPUTE」から「DYNAMIC_NODE」に変更され、ADCで変更が反映されませんでした。
解決方法
KB 000019890 Dell VxRail: ADCを手動でアップグレードして 最新のADCコードにアップグレードする方法
ADCのバージョンが1.5.306未満の場合は、スクリプトを手動で変更します。
- tcserverに変更します
vcluster101-vxrm:/home/mystic # su tcserver
- スクリプトに「COMPUTE」が含まれているかどうかを確認します
tcserver@vcluster101-vxrm:/home/mystic> grep "'COMPUTE'" /mystic/telemetry/DCManager/ADC/plugins/*.py
/mystic/telemetry/DCManager/ADC/plugins/collect_privileges.py: if 'COMPUTE' in cluster_type() and get_cluster_moid_from_config_service() == cluster.entity._moId:
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: if 'COMPUTE' in cluster_type(): # compute cluster is supported after AS
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: if 'COMPUTE' in cluster_type(): # compute cluster is supported after AS
tcserver@vcluster101-vxrm:/home/mystic>
- ADCが実行されているかどうかを確認し、停止します
tcserver@vcluster101-vxrm:/home/mystic> /mystic/telemetry/DCManager/bin/status.sh adc:adc-api RUNNING pid 2894, uptime 21:33:10 adc:adc-framework RUNNING pid 2893, uptime 21:33:10 datapolicy RUNNING pid 2861, uptime 21:33:15 update RUNNING pid 2936, uptime 21:33:04 tcserver@vcluster101-vxrm:/home/mystic> /mystic/telemetry/DCManager/bin/manual_stop.sh current VXM version +7.0.410 stoping DP...... datapolicy: stopped stopping ADC...... adc:adc-framework: stopped adc:adc-api: stopped 7.0.410 >= 7.0.350 current no support DT, since Magnus stopping UPDATE...... update: stopped tcserver@vcluster101-vxrm:/home/mystic>
- 変更する現在のファイルのバックアップを作成します
tcserver@vcluster101-vxrm:/home/mystic> cp /mystic/telemetry/DCManager/ADC/plugins/collect_privileges.py /mystic/telemetry/DCManager/ADC/plugins/collect_privileges.py.bak tcserver@vcluster101-vxrm:/home/mystic> cp /mystic/telemetry/DCManager/ADC/plugins/collectutil.py /mystic/telemetry/DCManager/ADC/plugins/collectutil.py.bak
- COMPUTEをDYNAMIC_NODEに置き換えます
tcserver@vcluster101-vxrm:/home/mystic> sed -i "s/COMPUTE/DYNAMIC_NODE/g" /mystic/telemetry/DCManager/ADC/plugins/collect_privileges.py tcserver@vcluster101-vxrm:/home/mystic> sed -i "s/COMPUTE/DYNAMIC_NODE/g" /mystic/telemetry/DCManager/ADC/plugins/collectutil.py
- 変更されたかどうかを確認する
tcserver@vcluster101-vxrm:/home/mystic> grep DYNAMIC_NODE /mystic/telemetry/DCManager/ADC/plugins/*.py
/mystic/telemetry/DCManager/ADC/plugins/collect_privileges.py: if 'DYNAMIC_NODE' in cluster_type() and get_cluster_moid_from_config_service() == cluster.entity._moId:
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: if 'DYNAMIC_NODE' in cluster_type(): # compute cluster is supported after AS
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: if 'DYNAMIC_NODE' in cluster_type(): # compute cluster is supported after AS
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: logger.info('[Collect Utils] Check cluster in vc: cluster type is DYNAMIC_NODE, moid: {}, cluster_moid: {}'.format(
/mystic/telemetry/DCManager/ADC/plugins/collectutil.py: '[Collect Utils] Check cluster in vc: cluster type is not DYNAMIC_NODE, vsanid: {}, cluster_id {}'.format(
tcserver@vcluster101-vxrm:/home/mystic>
- ADCの起動
tcserver@vcluster101-vxrm:/home/mystic> /mystic/telemetry/DCManager/bin/manual_start.sh
environment checking...
initialize database...
Checking supervisor.....
supervisor started!
No config updates to processes
Restarted supervisord
Check python version
Python version is 3+
File replace completed
current VXM version +7.0.410
Starting DP.....
datapolicy: started
Starting ADC.....
adc:adc-framework: started
adc:adc-api: started
7.0.410 >= 7.0.350
Don't support DT anymore for Magnus and Magnus+
Starting UPDATE.....
update: started
tcserver@vcluster101-vxrm:/home/mystic>
1+時間待ってから、CIQにアップデートが表示されるかどうかを確認します(バックエンド処理によってはさらに時間がかかる場合があります)。
対象製品
VxRail文書のプロパティ
文書番号: 000211280
文書の種類: Solution
最終更新: 24 2月 2026
バージョン: 4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。