PowerProtect Data Manager. Сбой обнаружения кластера Kubernetes — исключение ввода-вывода при следующем методе (поток был сбросить)

概要: Сбой обнаружения кластера Kubernetes в PowerProtect Data Manager — исключение ввода-вывода при следующем методе (поток был сбросить).

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Сбой обнаружения кластера Kubernetes в PowerProtect Data Manager.
В файле cndm.log наблюдается следующая ошибка:
2023-03-23T03:32:43.470Z ERROR [] [https-jsse-nio-127.0.0.1-8461-exec-3] [][][][TRACE_ID:9a9664af3ecde3e2;JOB_ID:9d8702e6e8798fea][] [c.e.b.c.d.s.CndmDiscoveryService.start(84)] -  discovery task failed
com.emc.brs.cndm.error.InternalServerErrorException: java.lang.RuntimeException: IO Exception during next method.
Caused by: java.lang.RuntimeException: IO Exception during next method.
Caused by: okhttp3.internal.http2.StreamResetException: stream was reset: INTERNAL_ERROR

原因

Продукт работает должным образом.

解決方法

В одном случае, когда это наблюдается, между PowerProtect Data Manager и кластером K8s имеется сервер Nginx. 

Измените следующие параметры в файле конфигурации Nginx /etc/nginx/default.d/server.conf
, proxy_redirect отключения.
proxy_buffering отключения;


После этого изменения обнаружение кластера PPDM Kubernetes выполняется нормально. 

対象製品

PowerProtect Data Manager
文書のプロパティ
文書番号: 000212870
文書の種類: Solution
最終更新: 18 5月 2023
バージョン:  2
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。