NetWorker:在 Linux 伺服器上nmc_config失敗,並顯示「Unable to Contact Authentication Server on Host Networker_server_hostname and Port 9090」

概要: 本文在 Networker 伺服器上將 NMC 設定為「警告」時提供警告:Linux 伺服器設定為 Proxy 主機時,無法在主機Networker_server_hostname和埠 9090」上聯絡驗證服務器。

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • NetWorker 管理主控台 (NMC) 伺服器安裝在 RHEL 型 Linux 作業系統上。
  • 執行 NMC 組態指令檔 (/opt/lgtonmc/bin/nmc_config) 時,無法聯絡 authc 埠 9090 上的驗證服務器。
[root@networker_server_hostname /]# /opt/lgtonmc/bin/nmc_config
The embedded web server inside the NMC server must run as a non-root user.
Dell recommends that you specify a user that has limited privileges and file access permissions. Default user name used is 'nsrnmc'.
Do you want to create new(cn) certificate or use existing(ue) certificate [cn]?
Create new certificate for https configuration.
Specify the directory to use for the LGTOnmc database[/nsr/nmc/nmcdb]:
Do you want to migrate the NMC server data from a previous LGTOnmc 8.x.x release [n]?
Specify the host name of the Networker Authentication Service host [Networker_server_hostname]:
WARNING: Unable to contact authentication server on host Networker_Server_hostname and port 9090
Do you want to specify a different authentication server host or port [y]?

原因

已在伺服器上啟用 Proxy。
 
  1. 以下錯誤來自 /opt/lgtonmc/logs/install.log
129356:gstauthcfg: Unable to get supported versions from authentication server: Received HTTP code 403 from proxy after CONNECT
Server Message : Make sure that server is running
  1. 下列命令顯示代理作用中:
[root@Networker_server_hostname /]# env |grep -i proxy
http_proxy=http://:8080
https_proxy=http://:8080

解決方法

注意:下列程式必須由 Linux 系統管理員執行。
  1. 請記下系統上設定的 Proxy:
[root@Networker_server_hostname /]# env | grep -i proxy
http_proxy=http://:8080
https_proxy=http://:8080
  1. 如果 Proxy 專案是在 /etc/profile 中指定,請對這些專案進行登出並登出。
  2. 再次登入 NetWorker 伺服器,然後重新執行 NMC 組態腳本:sudo /opt/lgtonmc/bin/nmc_config

対象製品

NetWorker

製品

NetWorker Family, NetWorker Series
文書のプロパティ
文書番号: 000216702
文書の種類: Solution
最終更新: 29 11月 2023
バージョン:  3
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。