Errore di backup Sybase NMDA "wrong ELF class: ELFCLASS64"

概要: Il backup Sybase ha esito negativo con errore "wrong ELF class: ELFCLASS64"

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

  • Il backup Sybase ha esito negativo.
  • Errore registrato durante il tentativo di backup
Backing up the database 'master'.
24146:nsrdasv: Error from server <SERVER NAME>: Msg 412402, Level 2, State 1
    Backup Server: 4.124.2.1: Archive API error for device='nsrsyb::master..1.1./nsr/apps/tmp/sybtmp_783.txt::000': Vendor application name=<UNINIT>, Library version=0, API routine=<UNINIT>, Message=Unable to open API library for device 'nsrsyb::master..1.1./nsr/apps/tmp/sybtmp_783.txt'. Library path is '/home/sybase15/ASE-15_0/lib/libnsrsyb.so'. dlopen() returned: Code=0, Message=ld.so.1: sybmultbuf: fatal: /home/sybase15/ASE-15_0/lib/libnsrsyb.so: wrong ELF class: ELFCLASS6424146:nsrdasv: Error from server < SERVER NAME>: Msg 8009, Level 16, State 1
    Error encountered by Backup Server.  Please refer to Backup Server messages for details.
142633:nsrdasv: Unable to back up the database 'master' in the instance '<SERVER NAME>'.
  • Sybase è Adaptive Server Enterprise (ASE) precedente alla 16.0 SP02.

原因

È stato installato il pacchetto NMDA a 64 bit. Poiché l'ambiente si trova su Solaris SPARC e ASE è sulla versione 15.7, NMDA a 32 bit deve essere installato sul client.

解決方法

Per determinare se è richiesto il software NMDA a 32/64 bit, il database o l'applicazione è a 32 bit o a 64 bit, indipendentemente dal fatto che il sistema operativo sia a 32/64 bit. NMDA a 32 bit è necessario per supportare un database server o un application server a 32 bit. NMDA a 64 bit per supportare un database o application server a 64 bit. Per le release Sybase ASE precedenti a 16.0 SP02, NMDA a 32 bit supporta sia Sybase ASE a 32 bit che a 64 bit su AIX e Solaris SPARC.

その他の情報

Questo è documentato nella NMDA Administration Guide
文書のプロパティ
文書番号: 000218115
文書の種類: Solution
最終更新: 08 1月 2024
バージョン:  1
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。