AppSync: Plan usług SQL nie powiódł się podczas fazy wykrywania aplikacji z błędem: Nie można połączyć się z bazą danych.

Podsumowanie: Plan usług SQL nie powiódł się podczas fazy wykrywania aplikacji z błędem: Nie można połączyć się z bazą danych Nie można połączyć się z bazą danych. Może się to zdarzyć, jeśli baza danych SQL nie jest w trybie online lub sterownik ODBC nie jest prawidłowo zainstalowany. Aby uzyskać więcej informacji, sprawdź dziennik wtyczki hosta AppSync. ...

Ten artykuł dotyczy Ten artykuł nie dotyczy Ten artykuł nie jest powiązany z żadnym konkretnym produktem. Nie wszystkie wersje produktu zostały zidentyfikowane w tym artykule.

Objawy

Plan serwisowy nie powiódł się podczas fazy wykrywania aplikacji z błędem: Nie można połączyć się z bazą danych Nie można połączyć się z nazwą bazy danych <Db>. Może się to zdarzyć, jeśli baza danych SQL nie jest w trybie online lub sterownik ODBC nie jest prawidłowo zainstalowany.
 Aby uzyskać więcej informacji, sprawdź dziennik wtyczki hosta AppSync.
 
Dzienniki zdarzeń AppSync:
 
Wykrywanie aplikacji, 7d2c438e-6ea7-4bb9-b515-0ce2594f9315, SQL_000141, <AppSync Server>, nie można połączyć się z nazwą bazy danych <Db>. Może się to zdarzyć, jeśli baza danych SQL nie jest w trybie online lub sterownik ODBC nie jest prawidłowo zainstalowany. Aby uzyskać więcej informacji, sprawdź dziennik wtyczki hosta AppSync.
 
Dzienniki serwera AppSync:
 
07-02-2021 06:00:05.840 INFO [Thread-28455 (BbQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [SQL_000141]: Nie można połączyć się z nazwą hosta bazy danych.master. Może się to zdarzyć, jeśli baza danych SQL nie jest w trybie online lub sterownik ODBC nie jest prawidłowo zainstalowany. Aby uzyskać więcej informacji, sprawdź dziennik wtyczki hosta AppSync. (METADANE: TYP BŁĘDU, TIME-2021-07-02 06:00:05.840-0600NATIVETIME-2021-07-02 06:00:05.643-0600, host-hostname.a.b.corporate. com, PHASE-Application discovery, THREAD=17152, USER-null, CATEGORY-GENERIC, SESSIONID-null)
07-02-2021 06:00:05.841 ERROR [Thread-28455 (ThreadQ-client-global-threads-320952484)] [org.jboss.as.ejb3.invocation] [] WFLYEJB0034: Wywołanie EJB nie powiodło się na składniku SqlServiceBean dla metody public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice.SqlServiceBean.discoverDatabases(com.emc.archway.context.ExecutionContext,com.com.) emc.archway.objectmodel.host.AgentHost,com.emc.archway.objectmodel.host.sql.SqlServerInstances) wyrzuca java.net.UnknownHostException,com.emc.archway.service.eventservice.exceptions.HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
07-02-2021 06:00:06.032 ERROR [Thread-28455 (Client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> exception occurred: RuntimeException
07-02-2021 06:00:06.035 ERROR [Thread-28455 (KasperskyQ-client-global-threads-320952484)] [com.emc..archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: EJBException, Komunikat: java.lang.RuntimeException
07-02-2021 06:00:07.272 INFO [Thread-28456 (LangQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [MILE_000005]: Faza wykrywania aplikacji dla nazwy hosta: narzędzie zakończone błędami (METADANE: TYP BŁĘDU, TIME-2021-07-02 06:00:07.272-0600NATIVETIME-2021-07-02 06:00:07.272-0600, HOST-ASServer, wykrywanie PHASE-Application, THREAD=Thread-28456 (PortugalQ-client-global-threads-320952484), USER-null, CATEGORY-MILESTONE, SESSIONID-null)

Przyczyna

Ochrona bazy danych SQL uległa awarii, ponieważ użytkownik dostarczony do AppSync for SQL nie miał wymaganych uprawnień.
 


Rozwiązanie


Zresetowanie uwierzytelniania bazy danych w systemie Windows do właściwego użytkownika rozwiąże problem.

Etapy resetowania uwierzytelniania:
 
1. W konsoli AppSync wybierz opcję Copy Management.
2. Z listy rozwijanej Kopie wybierz opcję Kopie.
3. Z listy rozwijanej Wybierz aplikację wybierz opcję Microsoft SQL Server, aby wyświetlić stronę instancji.
4. Wybierz bazę danych i kliknij opcję USTAWIENIA POŁĄCZENIA.
Zostanie wyświetlone okno dialogowe ustawień połączenia programu SQL Server.
5. W polu Uwierzytelnianie wybierz jeden z poniższych wymagań dla lokalizacji:
● Uwierzytelnianie systemu Windows
● Uwierzytelnianie serwera SQL
6. Określ wartości następujących pól:
● Nazwa użytkownika
● Hasło
7. Kliknij przycisk OK.

Produkty, których dotyczy problem

AppSync

Produkty

Data Protection, Data Backup & Protection Software
Właściwości artykułu
Numer artykułu: 000189823
Typ artykułu: Solution
Ostatnia modyfikacja: 11 maj 2026
Wersja:  7
Znajdź odpowiedzi na swoje pytania u innych użytkowników produktów Dell
Usługi pomocy technicznej
Sprawdź, czy Twoje urządzenie jest objęte usługą pomocy technicznej.