AppSync: SQL authentication fails after changing the connection credentials for SQL and then having one or a few successful runs.
Sammanfattning: AppSync: SQL authentication fails after changing the connection credentials for SQL and then having one or a few successful runs.
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Symptom
The password was changed for the SQL connection.
In the example provided in this article, the password was changed from 7 alphanumeric/symbol characters to 12.
Following that change, the Service Plan ran fine twice, but failed as this article documents on the third run.
After changing the credentials for a SQL connection, a service plan may run once or a few times successfully.
However after the one or few successful runs, the service plan fails with the following:
The AppSync CSV events will show:
The Source host AppSync Plugin log will show:
The AppSync Server log will show:
Note: The first or few successful runs may show a different number of asterisks in the server log if the new password contains a different number of alphanumeric/special characters. Like so in the below example where the password was changed from having 7 alphanumeric/special characters to 12.
In the example provided in this article, the password was changed from 7 alphanumeric/symbol characters to 12.
Following that change, the Service Plan ran fine twice, but failed as this article documents on the third run.
After changing the credentials for a SQL connection, a service plan may run once or a few times successfully.
However after the one or few successful runs, the service plan fails with the following:
The AppSync CSV events will show:
2019-10-10 09:52:02.18, Application discovery, ,GENL_000003,<source host>,Failed to authenticate using the provided credentials.
Verify that the credentials are correct and that the account has the required rights and privileges.
Additional information: Logon failure: unknown user name or bad password.
Verify that the credentials are correct and that the account has the required rights and privileges.
Additional information: Logon failure: unknown user name or bad password.
The Source host AppSync Plugin log will show:
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unique number>] SQL: Connecting to database <DBName>.master
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unique number>] SQL: impersonating <Domain\User>
2019-10-10 09:52:05.228 ERROR [<sourcehost>] [<unique number>] SQL: Failed to authenticate using the provided credentials. Verify that the credentials are correct and that they have the required rights and privileges. Additional information: Logon failure: unknown user name or bad password.
2019-10-10 09:52:05.197 INFO [<sourcehost>] [<unique number>] SQL: impersonating <Domain\User>
2019-10-10 09:52:05.228 ERROR [<sourcehost>] [<unique number>] SQL: Failed to authenticate using the provided credentials. Verify that the credentials are correct and that they have the required rights and privileges. Additional information: Logon failure: unknown user name or bad password.
The AppSync Server log will show:
10-10-2019 09:52:00.805 INFO [Thread-3009
</id><domain><Domain></domain><password>*******</password><username><User></username></credentials>
</id><domain><Domain></domain><password>*******</password><username><User></username></credentials>
10-10-2019 09:52:02.180 ERROR [Thread-3009 (HornetQ-client-global-threads-216778052)] [org.jboss.as.ejb3.invocation] [] [] WFLYEJB0034: EJB Invocation failed on component SqlServiceBean for method public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice. <removed>... HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
Note: The first or few successful runs may show a different number of asterisks in the server log if the new password contains a different number of alphanumeric/special characters. Like so in the below example where the password was changed from having 7 alphanumeric/special characters to 12.
10-10-2019 09:15:05.704 INFO [Thread-2952
</id><domain>MESSA</domain><password>************</password><username>User</username></credentials>
</id><domain>MESSA</domain><password>************</password><username>User</username></credentials>
Then on a subsequent failed run, notice the password is shorter:
10-10-2019 09:52:00.805 INFO [Thread-3009
</id><domain><Domain></domain><password>*******</password><username><User></username></credentials>
</id><domain><Domain></domain><password>*******</password><username><User></username></credentials>
Orsak
Software bug where AppSync is updating the credentials used a second and inappropriate time, which is during the service plan run.
Upplösning
Resolution:
A hotfix exists to resolve this issue for AppSync 3.8.
Quote this article when calling in a service request for the issue.
A hotfix exists to resolve this issue for AppSync 3.8.
Quote this article when calling in a service request for the issue.
Berörda produkter
AppSyncProdukter
AppSyncArtikelegenskaper
Artikelnummer: 000168662
Artikeltyp: Solution
Senast ändrad: 19 aug. 2025
Version: 4
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