MHC Azure Stack: OEM Type FirmwareCheckHealth of Role OEM raised an exception

摘要: Type FirmwareCheckHealth of Role OEM raised an exception Error running Test-OEMFirmwareHealth iDRAC has Critical Major faults could not proceed with Firmware update.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Precheck of OEM is failing Errors:
Oem Package Update
Perform Oem Extension update.

BeforeOEMUpdate
Tasks before OEMUpdate.

Test Firmware PreUpdate
Determine if OEM Firmware should be updated on physical nodes.

Firmware Check Health.
Check firmware health before update.

OEM.png

Click "Download Summary".

Error.json: 
Type ‘FirmwareCheckHealth’ of Role ‘OEM’ raised an exception:\n\nError running Test-OEMFirmwareHealth: iDRAC: 10.224.190.3 has Critical Major faults, could not proceed with Firmware update….

OEMerror.png
 

原因

Three of the four servers had memory errors. These need to be resolved before proceeding. 
The memory health monitor feature has detected a degradation in the DIMM installed in DIMM_A6. Reboot system to initiate self-heal process.

解决方案

To resolve this issue, fix the memory errors.

  1. Drain the node with the iDRAC showing the failed memory. 
  2. Once drained, run the following commands in a PEP PowerShell window. 
get-virtualdisk -cimsession "s-cluster"
get-virtualdisk -cimsession "s-cluster" | get-storagejob
  1. Once all storage jobs are complete, cold boot the server from the iDRAC
  2. Verify that the DIMM has healed:
    The self-heal operation successfully completed at DIMM DIMM_A6.
  3. In the Azure Stack window, Start the node.
  4. In the Azure Stack window, Resume the node.

受影响的产品

Integrated System for Microsoft Azure Stack Hub, Integrated System for Microsoft Azure Stack Hub 14G
文章属性
文章编号: 000200301
文章类型: Solution
上次修改时间: 08 9月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。