NetWorker 主控台:「無法開啟與連接埠 5672 上主機「NetWorker 伺服器」的插槽連線」
摘要: 嘗試在監控標籤下查看工作流程的詳細資料時,NetWorker Management Console (NMC) 上出現錯誤訊息:「訊息匯流排無法開啟連接埠 5672 上主機「Networkerserver_hostname」的插槽連線:發生套接字錯誤」出現在 NMC 中。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
NetWorker 伺服器和 NetWorker Management Console (NMC) 安裝在相同主機上。
NMC 監控視窗會顯示所有原則「永不執行
」;但備份和複製工作會依排程完成。
嘗試開啟工作流程或動作屬性時,NMC 中會出現下列錯誤:
圖 1:錯誤訊息的螢幕截圖:無法開啟連接埠 5672 上與主機的通訊端連線。
RabbitMQ 使用連接埠 5671 透過 SSL 進行通訊。
埠 5672 是用於非 SSL 通信的舊埠(不再使用)。
GSTD 會連線至 RabbitMQ,以使用連接埠 5671 取得和顯示 NMC 資訊。
當透過連接埠 5671 連線失敗時,NetWorker NMC 會進行故障復原,並嘗試執行 5672,但也會失敗,因為 RabbitMQ 不再使用此連接埠。
然後錯誤消息將問題報告為埠 5672,但問題確實出在與埠 5671 通信時。
NMC 監控視窗會顯示所有原則「永不執行
」;但備份和複製工作會依排程完成。
嘗試開啟工作流程或動作屬性時,NMC 中會出現下列錯誤:
Message bus unable to open socket connection to host "<NetWorker server hostname>" on port 5672: A socket error occurred
圖 1:錯誤訊息的螢幕截圖:無法開啟連接埠 5672 上與主機的通訊端連線。
RabbitMQ 使用連接埠 5671 透過 SSL 進行通訊。
埠 5672 是用於非 SSL 通信的舊埠(不再使用)。
GSTD 會連線至 RabbitMQ,以使用連接埠 5671 取得和顯示 NMC 資訊。
當透過連接埠 5671 連線失敗時,NetWorker NMC 會進行故障復原,並嘗試執行 5672,但也會失敗,因為 RabbitMQ 不再使用此連接埠。
然後錯誤消息將問題報告為埠 5672,但問題確實出在與埠 5671 通信時。
原因
GSTD 無法透過連接埠 5671 與 RabbitMQ 通訊。
通常這表示 RabbitMQ 服務已關閉,但也可能表示此連接埠存在一些連線問題 (如文章 210569 中所述)
通常這表示 RabbitMQ 服務已關閉,但也可能表示此連接埠存在一些連線問題 (如文章 210569 中所述)
- 如果 RabbitMQ 如預期運作,則 NetWorker 伺服器上的連接埠 5671 必須處於偵聽狀態。驗證埠 5671 是否處於偵聽狀態。若要檢查這些連接埠,請使用以下命令:
For Linux: netstat -ano | grep 5671 ss -ano | grep 5671 For Windows: netstat -ano | findstr 5671
- 如果未顯示連接埠,請確定 NSRD 服務正在執行中 (因此 RabbitMQ 應已開啟與此連接埠的連線)。
解析度
程序:
- 停止 NetWorker 服務。
- 前往 /nsr/tmp 資料夾,將 RabbitMQ 資料夾重新命名為 RabbitMQ_old。
- 啟動 NetWorker 服務。確認 /nsr/tmp 資料夾中產生了新的 RabbitMQ 資料夾。
- 檢查 NetWorker 伺服器上連接埠 5671 的狀態。
- 開啟 NetWorker Management Console 並檢查工作流程狀態。
- 如果問題已解決,請從 /nsr/tmp 刪除RabbitMQ_old。
其他資訊
連線測試命令:
請參閱相關的 Dell 文章:
Linux: curl -kv <NetWorker server>:5671 openssl s_client -connect <NetWorker server>:5671 Windows (PowerShell): tnc <NetWorker server> -port 5671
請參閱相關的 Dell 文章:
受影響的產品
NetWorker產品
Data Protection, NetWorker Family, NetWorker Series文章屬性
文章編號: 000200132
文章類型: Solution
上次修改時間: 09 10月 2024
版本: 9
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。