PowerProtect Data Manager: TSDM Backups Fail with Error InvalidProperty:vendorId

Summary: PowerProtect Data Manager backups using Transparent Snapshot Data Mover (TSDM) fail with the error InvalidProperty:vendorId. This issue originates from a misconfiguration or stale registration between VMware vCenter and the ESXi host, preventing snapshot creation by the Data Protection Service (DPS). ...

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Instructions

Symptoms

  • Backup jobs fail during snapshot creation.
  • Session logs show:
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
  • vSAN Health logs report:
DPD LRO request failed
Async LRO 'Snapshot' failed for 'vim.VirtualMachine'
  • dpd.log entries include:
Missing syncId
No VendorId provided
Task failed with error: InvalidArgument: invalidProperty = "vendorId"

Log Analysis:

Backup Session Logs:

  • Snapshot job fails
taskInfo.Error.Fault = '*types.InvalidArgument', InvalidProperty:vendorId
Unable to create LWD snapshot
DEBUG: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: taskInfo.Error.Fault = '*types.InvalidArgument', &{RuntimeFault:{MethodFault:{FaultCause:<nil> FaultMessage:[]}} InvalidProperty:vendorId}
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: vCenter task 'task-29959637' failed.
ERROR: [a2638cccf8b5d430;9ef9e6c1d992c6a3] SDM Data Mover: Create LWD Snapshot: Unable to create LWD snapshot.

vSAN Health logs:

  • Error Message Analysis

The recurring error:

(vmodl.fault.InvalidArgument) {
   invalidProperty = "vendorId"
}

This indicates that the vendorId property is either missing or invalid when the snapshot task is initiated. That is a direct clue that the system expects this property to be present and valid for the operation to succeed.

error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] DPD LRO request failed, host: host-#####(hostname), api: Snapshot, pe: (dp.vpx.VirtualMachineProtectedEntity) {
-->    vmRef = 'vim.VirtualMachine:vm-####',
-->    includedDiskKeys = (int) [
-->       2000,
-->       2001
-->    ]
--> }, dpdTask: 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a', dpsVcTask: 'vim.Task:task-30014504', dpd taskinfo: (vim.TaskInfo) {
-->    key = "Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a",
-->    task = 'vim.Task:Dp.Task.Snapshot.05709be7-b2be-4440-ac56-e4a74d30270a',
-->    name = "dp.ProtectionService.snapshot",
-->    descriptionId = "",
-->    state = "error",
-->    cancelled = false,
-->    cancelable = false,
-->    error = (vmodl.fault.InvalidArgument) {
-->       invalidProperty = "vendorId",
-->       msg = "",
-->    },
-->    progress = 0,
-->    reason = (vim.TaskReasonSystem) {
-->    },
-->    queueTime = "2025-09-19T00:06:24.000988Z",
-->    startTime = "2025-09-19T00:06:24.001002Z",
-->    completeTime = "2025-09-19T00:06:24.001186Z",
-->    eventChainId = 0,
-->    changeTag = "0",
--> }
2025-09-19T00:06:24.018Z error vsanvcmgmtd[63324] [vSAN@6876 sub=dps opId=9a108d6e-8d74] Async LRO 'Snapshot' failed for 'vim.VirtualMachine:vm-1964341', fault: (vmodl.fault.InvalidArgument) {
-->    invalidProperty = "vendorId",
-->    msg = "",
--> }

dpd.log:

Missing syncId
No VendorId provided

These messages confirm that the Data Protection Daemon (DPD) is unable to retrieve or assign the vendorId, which is essential for snapshot operations.

2025-09-22T06:54:01.265Z Er(163) dpd[2215779]: [Originator@6876 sub=VmomiProtectionService opID=9a42e00a-e00c] Missing syncId
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=VmomiProtectionService opID=9a42e0ac-e0ad] No VendorId provided
2025-09-22T06:54:06.012Z Er(163) dpd[2215778]: [Originator@6876 sub=Task opID=9a42e0ac-e0ad] Task 'Dp.Task.Snapshot.528967a1-7f4c-46d1-b3d1-db7a816732fb' failed with error: (vmodl.fault.InvalidArgument) {
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultCause = (vmodl.MethodFault) null,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    faultMessage = <unset>,
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    invalidProperty = "vendorId"
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: -->    msg = ""
2025-09-22T06:54:06.012Z Er(163) dpd[2215760]: --> }
2025-09-22T06:54:16.596Z Er(163) dpd[2215788]: [Originator@6876 sub=VmomiProtectionService opID=9a42e1fc-e1fd] Missing syncId
2025-09-22T06:54:18.724Z Er(163) dpd[2215768]: [Originator@6876 sub=VmomiProtectionService opID=9a42e23c-e23d] No VendorId provided`    
 

Cause

The ESXi host is not correctly registered with the Data Protection Service (DPS) in vCenter. As a result, the Data Protection Daemon (DPD) cannot retrieve or assign the required vendorId property, leading to snapshot task failures. This typically occurs due to:

  • Stale host registration in vCenter
  • vCenter not running the latest patch level
  • vSAN Health Service not functioning correctly

Context:

Architecture and workflow:

  • PowerProtect Data Manager uses VM Direct Engine → communicates with DPS in vCenter.
  • DPS locates the correct ESXi host and initiates tasks.
  • DPD on the host handles protection APIs and interacts with TSDM.

If the ESXi host is not properly registered with DPS/DPD, the vendorId is not assigned, which aligns with the failure.


Resolution

Coordinate with the VMware team to perform the following remediation steps:

  1. Restart the vSAN Health Service
    Alternatively, restart all vCenter services to refresh internal states.

  2. Reconnect the ESXi Host
    Disconnect and reconnect the affected ESXi host in vCenter to re-register it with DPS or DPD.

  3. Upgrade vCenter
    Ensure vCenter is updated to the latest build to resolve known API issues related to vendorId

Refer to the following related articles for additional context:

Affected Products

PowerProtect Data Manager

Products

Data Protection Suite Series
Article Properties
Article Number: 000381740
Article Type: How To
Last Modified: 18 رجب 1447
Version:  2
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