NetWorker Passive node backup fails for DISASTER_RECOVERY: save set

Summary: NetWorker Passive node backup fails for DISASTER_RECOVERY: save set.

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Symptoms

A Windows cluster is being backed up using the NetWorker client software.
The backup of the passive node fails with:

174424:save: Step (3 of 5) for PID-14480: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot:
176575:save: Unable to save the SYSTEM STATE save sets and create the snapshot.
176571:save: Step (4 of 5) for PID-14480: Unable to complete the backup of the disaster recovery save sets. See the savegrp log to track the closure steps of the backup.
176572:save: Error occurred during the backup of the disaster recovery save sets.


In the passive node's System Event viewer log, the following Volume Shadow Copy Service (VSS) errors are seen:

Volume Shadow Copy Service error: Unexpected error calling routine GetVolumePathName is fail on the path <>, winerror 0x00000002.. hr = 0x80070002, 
The system cannot find the file specified. 
Operation: PrepareForSnapshot Event Context: Execution Context: Writer Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220} Writer Name: System Writer Writer Instance ID: {df094dcb-34af-4112-a3a1-43febe923b77}

 

Cause

Application services run on a shared drive that is not locally associated with the passive node after failover.
The system writer reports the path where the application is running.  Volume Shadow Copy Service (VSS) reports that it cannot find the path where the service is running.

Resolution

Check 'list writers detailed' output.
Open CMD as admin and run the following:

diskshadow /l output.txt
DISKSHADOW> list writers detailed
DISKSHADOW> exit
 

1. From the NetWorker Management Console (NMC) open the passive node's client properties.
2. In the Apps & Modules tab, edit the Save operations field to contain: 

VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=yes

 

Additional Information

If the above does not help resolve the issue, follow the steps below and engage support to assist.

Copy vsstrace and vssagent binaries to the problematic client. They collect a lot of Microsoft VSS debug information.

Perform the following and collect the outputs:

  1. Add the following syntax to the client "Backup operations" field: VSS:NSR_SYS_WRITER_WIN32_SERVCOMP_USER=yes
  2. Set the backup command to save -D9 -vvvv  in NMC client's properties.
  3. "save -o VSS:LCV=yes" output on the problematic client
  4. savefs -p output on the problematic client.
  5. lcmap  output on the problematic client.
  6. Before starting the backup, start the vsstrace and vssagent collection on the problematic client with two different cmd :-  vsstrace -l 255 +f 0xffff -o C:\vss.trace.log
  7. Start the backup from the NMC
  8. Wait for the backups to finish.
  9. Collect output of "vssagent -gather C:\VSS.xml"
  10. Collect NSRGET and Reports from the problematic Client

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000168983
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
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