iDRAC9: Unable to Collect Remote SupportAssist with Debug Option

Summary: Dell RACADM may fail the remote SupportAssist log collection when the debug option selected and the collection are at max file size.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The remote SupportAssist Collection fails to export with the debug option.
[root@server]# racadm -r %idrac% -u %user% -p %password% -d supportassist collect -t Debug -f TSR.zip
Security Alert: Certificate is invalid - self signed certificate in certificate chain
Continuing execution. Use -S option for racadm to stop execution on certificate-related errors.
Job ID = JID_309193470707

Please wait while the SupportAssist collection is completed
ERROR: HTTP Service unavailable for the specified RAC.
ERROR: Unable to process the HTTP command request. Please retry the command after some time.
Please wait while the logs are being fetched. Depending on the network speed,
it may take several minutes to complete this operation.

Progress = -9223372036854775808 percent

Cause

With the debug option selected, additional files are added to the collection. This can cause the collection to reach the maximum size of 30 MB. When the collection is pulled remotely and at the max size, it can cause the system-httpd.slice to exceed the max memory. As a result the system recycles the processes in the cgroup to get back under the memory limit and results in collection failure. 

Resolution

Future iDRAC9 Firmware 7.20.10.50 will automatically cleanup old corefiles to reduce debug collection size.

Use one of the following options to export the debug SupportAssist collection. 

Option 1
The core files can be deleted before pulling a remote collection to reduce the collection size. 

$ racadm -r %idracip% -u %user% -p %password% coredump 
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete -f %filename%
$ racadm -r %idracip% -u %user% -p %password% coredumpdelete --all

Option 2
The debug SupportAssist collection can be pulled locally from the host system using local racadm. Using this method is not impacted as it does not run under the same cgroup memory limits as remote racadm

$ racadm supportassist collect -t debug -f TSR.zip


 

Affected Products

iDRAC9
Article Properties
Article Number: 000251323
Article Type: Solution
Last Modified: 19 May 2025
Version:  3
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