VxRail: VSAN tab is missing in the HTML5 client
Summary: Virtual Storage Area Network (VSAN) tab is missing in the HTML5 client post upgrade to 4.7.x version (VCSA 6.7).
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The VSAN tab is missing in the HTML5 client after an upgrade to 4.7.x version (VCSA 6.7).
Cause
The com.vmware.vsphere.client.h5vsan-6.7.0.20000 directory might be missing in the vsphere-client-serenity directory.
Resolution
To resolve this issue, follow this workaround:
- SSH to the affected vCenter
- Change to directory:
/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity. - Confirm that the directory
com.vmware.vsphere.client.h5vsan-6.7.0.20000is missing. - Create a new directory called
com.vmware.vsphere.client.h5vsan-6.7.0.20000. - SSH to the working vCenter.
- Confirm that the directory
/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000is present on the appliance. - Use WinSCP to connect to the working vCenter and copy the
com.vmware.vsphere.client.h5vsan-6.7.0.20000contents to the local machine. - Copy the files from the local machine to the newly created directory on the affected vCenter.
- Run the following command on the affected vCenter to change the ownership of all files and subdirectories to
vsphere-ui users.
Find/etc/vmware/vsphere-ui/vc-packages/vsphere-client-serenity/com.vmware.vsphere.client.h5vsan-6.7.0.20000xargs chown vsphere-ui:users
- Should VCHA be enabled, put this into Maintenance Mode to prevent a failover.
- Reboot the affected vCenter virtual machine and wait for the plugins to load.
- Confirm that the VSAN plug-in tab is present in the vSphere Client.
Affected Products
VxRail Appliance Family, VxRail D560, VxRail D560F, VxRail E460, VxRail E560, VxRail G560, VxRail G560F, VxRail V470Products
VxRail Appliance FamilyArticle Properties
Article Number: 000082394
Article Type: Solution
Last Modified: 07 Apr 2026
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.