NVP vProxy: Troubleshooting VM backups fail with "VDDK Error 13: You do not have access rights to this file"

Summary: NetWorker VMware Protection (NVP) vProxy appliance fails to backup one or more hard disks. The error returned is VDDK Error 13 "You do not have access rights to this file." This is a general error which translates to "I cannot access this file." The common causes are communication, permissions, or configuration issues. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VMware Virtual Machine backups fail with:

Failed to backup virtual disk "Hard disk #".  Failed to initialize Block Reader.  Failed to open source VMDK '[DATASTORE] VM_NAME/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.

This message can be found in the Virtual Machine (VM) backup session log as seen through the NetWorker Management Console's (NMC) backup action details. The VM session logs are also stored in the following locations:

NetWorker Server: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/
vProxy Appliance: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE

Cause

This Virtual Disk Development Kit (VDDK) error is reported to vProxy by VMware. Error 13 is a general access error indicating that there are either permissions or communications issues preventing the vProxy from successfully accessing the VM files. 

Resolution

NOTE: Issue-speciific articles can be found in the Additional Info section of this article. Most of the causes for this error can be identified using the ProxyHC utility. In some instances, the ProxyHC utility can resolve issues causing this failure to appear.

Getting ProxyHC and moving it to the vProxy:

ProxyHC can be collected from the customer facing NetWorker Tools page: https://central.dell.com/solutions/Networker-Tools

Copying ProxyHC to the vProxy appliance:

The package can be copied to the vProxy appliance using an SCP agent (WinSCP, FileZilla, and so on). 

User: admin (root is blocked over SSH by default).
Protocol: SCP

Or from the Windows command line (if server 2019 or newer, or OpenSSH is installed).
scp source admin@vProxy_address:/home/admin/ProxyHC
Where source is the full path to the extracted ProxyHC file on the Windows system.

Extra instructions for copying files to a Linux system can be found under:  
NetWorker (Linux): How to copy files to/from a Linux NetWorker server.

Using ProxyHC:

Confirm that no VM backups are running through the vProxy appliance and perform the following:
  1. Connect to the vProxy over SSH using the admin account.
  2. Switch to the root user:
sudo su -
  1. Make ProxyHC executable:
chmod +x /home/admin/ProxyHC
  1.  Run ProxyHC with the following flags: 
/home/admin/ProxyHC auth port perm tasks disk cleanup hotadd
 
ProxyHC Switches
auth Prompts user to validate NetWorker admin credentials and authentication with the vCenter. Enter the vCenter user account used to add vCenter to NMC's VMware View.
port Check required port communication between vProxy appliance, Data Domain, ESXi hosts, and vCenter.
perm This identifies if the vCenter user is missing any permissions that are required to perform backups.
tasks Check for orphaned backup tasks in the vCenter.
cleanup Check for leftover artifacts from previous backups: disks, locks, annotations. It asks you if you would like to remediate for all vProxies in the vCenter. If there are no VM backup/restore operations running, enter Y. If other vProxies are performing backup/restore operations, enter N.
hotadd Enter the DNS name (not VM name). The DNS name of the VM can be queried using nslookup command or in the DNS field of the VMs summary tab in vSphere. This checks that the vProxy has hot add access to the VM's files.


If the cleanup flag indicated that operations were performed (disks removed, locks released, annotations cleared), re-attempt backup. If any failures are reported, review the vProxy's /tmp/proxy-hc.log. The output identifies what is missing and needed or isolates 'you do not have access rights' to a specific cause. References for specific causes can be found under "Additional Info."
 

Additional Information

KBs with specific causes for VDDK Error 13:

Extra Resources:

Other options for ProxyHC:

usage: ProxyHC vCenter [-h] --name NAME --user USER [--pwd PWD] [--vm VM]
                       [--nsruser NSRUSER] [--nsrpwd NSRPWD]
                       [--nsrauthc NSRAUTHC] [--allproxies ALLPROXIES]
                       [--DDhost DDHOST]
                       {auth,port,perm,disk,hotadd,migration,listsession,annotation,cleanup,kb524127,all,layout,tasks,datastore,vmsnapchain,vmdisksize,termsoapsession}
                       ...

positional arguments:
  {auth,port,perm,disk,hotadd,migration,listsession,annotation,cleanup,kb524127,all,layout,tasks,datastore,vmsnapchain,vmdisksize,termsoapsession}
                        sub-command help
    auth                test authentication against vCenter server
    port                check open ports to ESXi hosts in cluster and data
                        domain systems
    perm                check vCenter access permissions
    disk                check & release extra disks from vProxy
    hotadd              check for hotadd access to provided VM
    migration           check vCenter for stale migration locks
    listsession         print login session list to log
    annotation          check vCenter for stale backup locks(annotations)
    cleanup             remove left over artifacts(extra disks,
                        locks/annotations) and find migration locks.
    kb524127            check for invalid state of vProxy VM
    all                 All vCenter tools(combination of port, perm and
                        cleanup)
    layout              check for description of files that make up VM
    tasks               check orphaned tasks in vCenter
    datastore           look for datastores with unsupported names
    vmsnapchain         check if any protected VM has excessive child disks
    vmdisksize          check if any protected VM has irregular disk size i.e.
                        trailing .5 KB
    termsoapsession     terminate soap session to vCenter from NWS

optional arguments:
  -h, --help            show this help message and exit
  --name NAME           hostname of the vCenter server
  --user USER           user name for login to vCenter server
  --pwd PWD             password for login to vCenter server
  --vm VM               DNS name of VM(as shown in vSphere)
  --nsruser NSRUSER     user name for login to NetWorker server
  --nsrpwd NSRPWD       password for login to NetWorker server
  --nsrauthc NSRAUTHC   Remote AuthC server
  --allproxies ALLPROXIES
                        specify to do work on peer vProxies registered
  --DDhost DDHOST       provide DD IP/hostname for port connectivity tests

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000207076
Article Type: Solution
Last Modified: 24 Oct 2025
Version:  8
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