Data Domain – BoostFS-problem med säkerhetsskannerprogramvara eller -appar
Summary: Boostfs på Linux- och Windows-klienten beter sig oväntat när säkerhetsgenomsökning eller säkerhetsprogram söker igenom eller får åtkomst till filer i en Boostfs-monteringspunkt.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Den monterade enheten eller monteringspunkten från BoostFS svarar inte.
Säkerhetskopieringsåtgärderna från programmet kan misslyckas med misslyckade läsningar och skrivningar på filerna på monteringspunkten. Exempel:
Prestandaförsämring. Läs- eller skrivåtgärderna (säkerhetskopiering eller återställning) blir långsamma.
Säkerhetskopieringsåtgärderna från programmet kan misslyckas med misslyckade läsningar och skrivningar på filerna på monteringspunkten. Exempel:
Apr 19 10:15:09.853 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002] Apr 19 10:15:13.990 29214 2269886208 [E] [ddp log] [721E:7FC860125190] ddcl_ddcp_pwrite: Error in ddcl_ddcp_pwrite. [ERR=5002]
Boostfs verkar ha återkommande frånkopplings- och försöksfel.
Feb 24 19:52:46.803 423080 2833229568 [I] bfs_node_lookup: failed to obtain a connection; file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2 Feb 24 19:52:46.803 423080 2833229568 [E] bfs_node_retry_conn: lookup failed path=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2 Feb 24 19:52:46.803 423080 2833229568 [E] bfs_open: lookup failed file=/image/azprd/20210224_test/data_D-AZPRD_I-1811368087_TS-CITBSP_FNO-1061_auvo0tkc err=2 Feb 24 19:52:46.803 423080 2833229568 [P] BFSPROC_EXIT_bfs_open: rc=-11
Prestandaförsämring. Läs- eller skrivåtgärderna (säkerhetskopiering eller återställning) blir långsamma.
Cause
- Säkerhetsgenomsökningsprogrammet eller programmen som är installerade på datorn söker även igenom Boostfs-monteringspunkten tillsammans med andra enheter och mappar
- BoostFS rekommenderar inte att flera program, inklusive säkerhetsskannrar, får åtkomst till BoostFS-monteringspunkten samtidigt.
- Det kan leda till fel beroende på vilken typ av åtkomst det är eftersom en enda filkontext underhålls i BoostFS.
- Dessutom kan antivirus-/säkerhetsgenomsökningsprogramvara förhindra vissa filsystemsspecifika åtgärder.
Sortering:
Kontrollera "app-info" i Boostfs-loggmeddelanden. Detta fylls i med namn på antivirus-/säkerhetsgenomsökningsprogram. Här är "s1-agent" och "s1-fanotify" säkerhetsprogramnamnen
ddboostfs_0_0.log:265760:Apr 21 16:51:09.048 26822 1603430144 [D] bfs_get_app_info: app_info=s1-agent ddboostfs_0_0.log:266094:Apr 21 16:51:10.102 26822 1603430144 [D] set_conn_app_info: app_info=s1-agent Feb 24 19:52:46.803 423080 2394937088 [D] bfs_get_app_info: app_info=s1-fanotifyDet innebär att skannerns programvara kommer åt Boostfs-monteringspunkten.
Kontrollera programmet i DDBOOST-anslutningarna som beskrivs i DD ASUPs
DDBOOST Connections Detailed with-fips-mode ----------------------------Active Clients: 5Clients: Client Idle CPUs Memory(MiB) Plugin Version OS Version Application Version Encrypted DSP Transport FIPS mode -------------------------------- ---- ---- ----------- --------------- -------------------------------------------------------- ------------------------------------------------ --------- --- --------- ----------- c3po01 YES 14 64,152 7.7.4.0-1017373 Linux 4.1.12-124.67.3.el7uek.x86_64 x86_64 BOOSTFS:7.7.4.0-1017610 FUSE:2.9.4 s1-agent NO YES IPv4 NO
Kontrollera slutligen inställningarna för skannerprogram om de innehåller boostfs-monteringspunkter/monterade enheter.
Resolution
Vi rekommenderar att du utför antivirusskanningar utanför åtgärdsfönstret i Boostfs.
Kontrollera om inställningarna för security scanner kan ändras så att de inte kan koppla boostfs-monteringspunkter från skanning och andra åtgärder som utförs av det.
Kontrollera om inställningarna för security scanner kan ändras så att de inte kan koppla boostfs-monteringspunkter från skanning och andra åtgärder som utförs av det.
Additional Information
- Den här artikeln gäller alla BoostFS-versioner oberoende av vilken säkerhetsskannerprogramvara som är installerad på den.
- De problem som rapporterats gäller flera säkerhetsskannrar, inklusive Carbon-Black, McAfee, Fanotify, s1-agent, CrowdStrike med mera.
Affected Products
Data DomainArticle Properties
Article Number: 000215701
Article Type: Solution
Last Modified: 26 Jan 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.