PowerStore: NTPD hizmet hatası, düğümün yeniden başlatılmasıyla sonuçlanmıştır

Summary: Svc_ntp_ctl komutu kullanırken beklenmedik bir düğüm yeniden svc_ntp_ctl gözlemlendi.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Aşağıdaki senaryolarda svc_ntp_ctl --set komutu kullanıldığında beklenmedik bir düğümün yeniden başlatılması gözlemlenir:
  • Paralel veya kısa bir süre içinde birden fazla oturum aracılığıyla bir düğümde birden fazla kez yürütülür
  • Her iki düğümde de paralel olarak veya kısa bir süre içinde birden fazla kez yürütülür
WebUI, REST API veya PSTCLI üzerinden NTP sunucu ayarı güncelleştirmeleri uygularken svc_ntp_ctl --set komutu yürütülürse aynı belirti oluşabilir.

Düğüm yeniden başlatılır ve otomatik olarak kurtarılabilir.

Cause

Başka bir svc_ntp_ctl eş zamanlı svc_ntp_ctl --set komutları çalıştırarak veya NTP sunucu güncelleştirme isteğiyle bağlantı noktasını tutan bir işlem varsa --set komutu ntpd bağlantı noktasını dahili olarak bağlayamayabilir.
PowerStoreOS 3.0 ve 3.2'de, ntpd hizmeti bir arızadan hemen sonra yeniden başlatmayı dener, bu nedenle bu koşul kapsamında yeniden başlatma sayısını hızlıca tüketer ve servisin başarısız olduğunu bildirir.
Düzenleme HA politikasının tasarımı nedeniyle sistem, ntpd hizmeti kendi kendine kurtarma eylemlerinin bir parçası olarak başarısız olduğunda proaktif olarak bir düğüm yeniden başlatma işlemi başlattı.

Resolution

Bu sorun PowerStoreOS 3.5'te düzeltmiştir.

Bu Sorunun Meydana Etmesini Önlemek için Geçici Çözüm
Sorunun meydanaılmasını önlemek için svc_ntp_ctl --set command one at a time on an appliance, only when needed( yalnızca gerekli olduğunda) komutunu çalıştırın.
Ayrıca PowerStore Manager kullanıcı arayüzü, REST API veya PSTCLI üzerinden NTP sunucu ayarı güncelleştirmelerini uygularken svc_ntp_ctl --set komutunu çalıştırabilirsiniz.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000215670
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.