PowerStore: NTPD service failure results in a node reboot

Summary: An unexpected node reboot may be observed when using svc_ntp_ctl command.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

An unexpected node reboot may be observed if the svc_ntp_ctl --set command is used in of the following scenarios:
  • Executed multiple times on one node via multiple sessions either in parallel or in a short period of time
  • Executed multiple times on both nodes either in parallel or in a short period of time
The same symptom may occur if the svc_ntp_ctl --set command is executed while applying NTP server setting updates through the WebUI, REST API, or PSTCLI.

The node reboots and automatically recovers.

Cause

The svc_ntp_ctl --set command may fail to bind the ntpd port internally if another process is holding the port by running concurrent svc_ntp_ctl --set commands or by an NTP server update request.
On PowerStoreOS 3.0 and 3.2, the ntpd service attempts to restart immediately after a failure, so it will quickly exhaust its restart count under this condition and declare the service failed.
Due to the design of the orchestration HA policy, the system proactively initiated a node reboot when the ntpd service failed as part of self-recovery actions.

Resolution

This issue is fixed in PowerStoreOS 3.5.

Workaround to Prevent this Issue from Occurring
To prevent the issue from occurring, run the svc_ntp_ctl --set command one at a time on an appliance, only when needed.
Also, do not run the svc_ntp_ctl --set command while applying NTP server setting updates through the PowerStore Manager UI, REST API, or PSTCLI.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000215670
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
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