PowerStore: Ein NTPD-Serviceausfall führt zu einem Node-Neustart.

Summary: Bei Der Verwendung svc_ntp_ctl Befehls kann ein unerwarteter Node-Neustart beobachtet werden.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ein unerwarteter Node-Neustart kann beobachtet werden, wenn der Befehl svc_ntp_ctl --set in den folgenden Szenarien verwendet wird:
  • Mehrmals auf einem Node über mehrere Sitzungen ausgeführt, entweder parallel oder in kurzer Zeit
  • Mehrmals auf beiden Nodes ausgeführt, entweder parallel oder in kurzer Zeit
Das gleiche Symptom kann auftreten, wenn der Befehl svc_ntp_ctl --set ausgeführt wird, während NtP-Servereinstellungsaktualisierungen über die WebUI, REST API oder PSTCLI angewendet werden.

Der Node wird neu gestartet und wird automatisch wiederhergestellt.

Cause

Der Befehl "svc_ntp_ctl --set" kann den ntpd-Port möglicherweise nicht intern binden, wenn ein anderer Prozess den Port hält, indem gleichzeitige svc_ntp_ctl --set-Befehle oder eine NTP-Serveraktualisierungsanforderung ausgeführt werden.
Auf PowerStoreOS 3.0 und 3.2 versucht der ntpd-Service, unmittelbar nach einem Ausfall neu zu starten, sodass die Neustartanzahl unter dieser Bedingung schnell ausgeschöpft wird und der Service als fehlgeschlagen deklariert wird.
Aufgrund des Designs der HA-Policy für die Orchestrierung initiierte das System proaktiv einen Node-Neustart, wenn der ntpd-Service im Rahmen von Self-Recovery-Aktionen fehlschlug.

Resolution

Dieses Problem wurde in PowerStoreOS 3.5 behoben.

Problemumgehung, um zu verhindern, dass dieses Problem auftritt
Um zu verhindern, dass das Problem auftritt, führen Sie den Befehl svc_ntp_ctl --set nacheinander auf einer Appliance nur bei Bedarf aus.
Führen Sie außerdem den Befehl svc_ntp_ctl --set nicht aus, während Sie Aktualisierungen der NTP-Servereinstellungen über die PowerStore Manager-Benutzeroberfläche, REST API oder PSTCLI anwenden.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000215670
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.