Data Domain: REST API error - REST service is disabled

Summary: How to resolve REST Application Programming Interface (API) errors.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Identified Symptoms

The following symptoms have been identified:

  • Cyber Recovery UI errors
    • "Got HTTP response code 400 Bad Request while login to DD using REST API" error message
  • "REST service is disabled" error message when trying to connect to DD on port 3009 using browser or API call

Cause

Root Cause of the Issue

The root cause of the issue is that the REST service is disabled on the Data Domain.

This can be due to the web service being disabled, which is required for the REST service to run.

  • REST service is disabled
  • Web service is disabled

Relevant Error Messages

Relevant error messages that indicate the cause of the issue include:

  • "REST service is disabled"
  • "Got HTTP response code 400 Bad Request while login to DD using REST API"
# Relevant command to check the status of the web service
$ adminaccess enable web-service

Resolution

Enabling REST Service on Data Domain

To resolve the REST API error, the REST service on the Data Domain must be running. This can be achieved by enabling the web service.

# Enable web service using the following CLI command
adminaccess enable web-service

Once the web service is enabled, the REST service runs, allowing REST API calls to complete successfully.

Verifying the Resolution

To verify that the issue has been resolved, attempt to connect to the Data Domain on port 3009 using a browser or API call. If the REST service is running, the "REST service is disabled" error does not appear.

Caution: If the issues is still occurring, contact Dell Support.

Affected Products

PowerProtect Cyber Recovery, DD OS
Article Properties
Article Number: 000353903
Article Type: Solution
Last Modified: 07 Aug 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.