Data Domain: Entegre yedekleme yazılımında veya DPA'da izleme hizmetlerinin devre dışı kalmasına neden olan yaygın SNMP yapılandırması sorunları (İngilizce)

Summary: Yaygın SNMP sorunlarını giderin. Data Domain'deki SNMP yapılandırması ve Sorunları, Tümleşik Yedekleme Yazılımında veya DPA'da İzleme Servislerinin devre dışı bırakılma neden olur. Çözüme kadar tüm adımlar sıralı ve zorunludur. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Data Domain'de Yaygın SNMP yapılandırma Sorunları, Tümleşik Yedekleme Yazılımında veya DPA'da İzleme Servislerinin devre dışı bırakılma neden olur. Çözüme kadar tüm adımlar sıralı ve zorunludur.

1. Avamar'da MCS, DD durumu yanıt vermez ve Sunucu Yönetimi'ne aşağıdaki hataları gösterir:
  • SNMP dosya sistemi durumu alınamıyor
  • Dosya sistemi bilgileri alınamıyor
  • Dosya sistemi devre dışı
  • Data Domain sistemindeki SNMP topluluk dizesi eksik
    Sistem Bilgileri
2. Networker'da DD'nin SNMP izleme durumu boş kalır ve SNMP yapılandırma sorunu
3'ü rapor eder. DPA herhangi bir raporu çalıştıramayabilecektir<ve ana bilgisayar dd_name> veya geçersiz kimlik bilgileri sağlanmıştır.

Cause

  • Dahili ağ sorunu nedeniyle DD ve Yedekleme Yazılımı/DPA arasında iletişim kanalı bozuk
  • 161 ve 163 numaralı bağlantı noktası kuruluş güvenlik duvarında engellenmiş
  • DDBOOST kullanıcı Parolasının süresi, 90 günlük parola değişikliği/oluşturma sonrasında otomatik parola sona erme ilkesi nedeniyle sona erer.
  • SNMP yapılandırması Data Domain'de geçersiz

Resolution

Dahili ağ sorunu nedeniyle DD ve Yedekleme Yazılımı/DPA arasında iletişim kanalı bozuk
  • DD CLI'de oturum açın ve SE Moduna açılır 
  • DD'den Ping/net arama Yedekleme yazılımı IP'si ve ana bilgisayar adı
    • # ping 10.0.0.1
    • # net lookup avamar.domain.local
  • Aynı işlemi yedekleme yazılımı ucundan gerçekleştirin
    • # ping 10.0.0.10
    • # nslookup datadomain.domain.local
  • Ping yanıtı alamıyorsanız veya net arama çalışmıyorsa müşteriye DD ve yedekleme yazılımının artık birbiriyle iletişim kurmadığını bildirin. Müşterinin sorunu çözmek için yerel ağ ekibiyle iletişime geçmesi gerekir.
  • Tam olarak nerede olduğunu görmek için bir tracepath veya traceroute çalıştırın.
    • # se tracepath 10.0.0.1
    • # se traceroute 10.0.0.1
161 ve 163 numaralı bağlantı noktası kuruluş güvenlik duvarında engellenmiş
  • DD CLI'de oturum açın ve SE Moduna açılır 
  • Bağlantı noktası 161 ve 163 için telnet ile Tuzak Ana Bilgisayar IP'si arasında bağlantı kurun
    • # se telnet 10.0.0.1 161
    • # se telnet 10.0.0.1 163
  • SNMP bağlantı noktalarını görmek için fwchk komutunu da deneyin:
    • # se fwcheck 10.0.0.1

Telnet veya PORT 161 NOK, PORT 163 NOK(BAĞLANTı NOKTASı 163 NOK) öğesinin fwcheck'te (Bağlantı Zaman Aşımı) olduğunusanız bu durum, kuruluş güvenlik duvarının SNMP bağlantı noktalarını engellediğinden emin olur. Müşterinin bu bağlantı noktalarının çift yönlü olması için ağ/Güvenlik Duvarı ekibiyle kontrol olması gerekir.

DDBOOST kullanıcı Parolasının süresi, 90 günlük parola değişikliği/ayarlama sonrasında DD'de otomatik parola sona erme ilkesi nedeniyle sona erer
  • Yönetici Modu ile DD'de oturum açın
  • Mevcut ddboost kullanıcılarını kontrol edin
    • # ddboost user show
  • Çok sayıda ddboost kullanıcısı varsa Hangi ddboost kullanıcısı kullanılır? Yedekleme yazılımını/DPA'yı kontrol edin.
  • Parola durumunu kontrol edin:
    • # user show detailed <ddboost_username>
  • Parolayı değiştirmek veya parola süresini uzatmak ancak parola süresini uzatmak en kısa yol olur.
    • # user password aging set <ddboost_username> max 999999
  • Ardından Yedekleme yazılımı/DPA'da DD'yi yeniler.
SNMP yapılandırması Data Domain'de Geçersiz
  • Avamar ve DPA'nın salt okunur topluluk dizelerini kullanmalarını tavsiye eder
  • Avamar topluluğu diğer yedekleme yazılımıyla paylaşılamamalı
  • Varsayılan SNMP bağlantı noktalarını tuzak için tutmak daha iyidir
  • Data Domain sürümü 5.5.x'den büyükse veya bu sürüme eşitse lütfen tuzaklı hizmeti etkinleştirmeyin
  • Mevcut SNMP yapılandırmasını ve durumunu görmek için:
    • # snmp status
    • # snmp sh config
Yukarıdakilere göre önerilmeyen bir şey görmüyorsanız yapılandırmayı değiştirin:
  • Ör. için bir topluluk ekleme: Yalnızca Avamar:
    • # snmp add ro-community Avamar-only
  • v2c'ye sahip avamar topluluğuna bir tuzak ana bilgisayar ekleyin:( Varsayılan Bağlantı Noktası ile)
    • # snmp add trap-host avamar.domain.local version v2c community Avamar-only
  • v2c'ye sahip avamar topluluğuna bir tuzak ana bilgisayar ekleyin:(With Dedicated Port)
    • # snmp add trap-host avamar.domain.local:163 version v2c community Avamar-only
  • Tuzak ana bilgisayarlarını silme:
    • Tüm tuzak ana bilgisayarlarını silinmesi gerekiyorsa: # snmp reset trap-hosts
    • Tek bir tuzak ana bilgisayarı silmek için: # snmp del trap-host <trap_hostname>
    • Bir topluluğu silmek için tüm tuzak ana bilgisayarlarını serbest bırakmamız gerek. Ardından, topluluğu şu şekilde sildirin:
      • # snmp del ro <community_name>
    • Avamar, Networker, DPA için Sağlıklı SNMP V2C yapılandırmasına örnek olarak aşağıdaki gibi görün gerekir:
      • ddboostadmin@dd-hostname# snmp show config
        General Configuration
        ---------------------
        SNMP sysLocation: Databacenter
        SNMP sysContact: suportebackup@customername.com.br
        SNMP sysNotes:
        SNMP v2c Configuration
        ----------------------
        Community           Access      Hosts
        -----------------   ---------   -----
        Avamar-only         read-only
        Networker           read-only
        Dpa                 read-only
        -----------------   ---------   -----
        Trap Host                        Port       Community
        ------------------------------   -------   ---------
        avamar.domain.local              Default    Avamar-only
        networker.domain.local           Default    Networker
        dpa.domain.local                 Default    dpa
        ------------------------------   -------   ---------
        SNMP v3 Configuration
        ---------------------
        User   Access   Authentication Protocol   Privacy Protocol
        ----   ------   -----------------------   ----------------
        ----   ------   -----------------------   ----------------
        Trap Host   Port   User
        ---------   ----   ----
        ---------   ----   ----

Additional Information

Not: ddboost parolasını değiştirirseniz yedekleme yazılımında da aynı güncelleştirmesi unutmayın; aksi takdirde yedeklemeler başarısız olur.
Not: 5 dakika sonra DD durumunda herhangi bir değişiklik yoksa Avamar'da SNMP hizmetini yeniden başlatmanız gerekir. Avamar için 5 dakika kapalı kalma süresi gerekir. Avamar kök moduna açılır ve aşağıdaki komutu çalıştırın:
  • # mcddrsnmp restart
Referans Materyali:

Affected Products

Data Domain

Products

Avamar, Data Protection Advisor, DD OS, NetWorker
Article Properties
Article Number: 000063895
Article Type: Solution
Last Modified: 15 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.