PowerStore: Impossibile modificare l'autenticazione da semplice a Kerberos tramite GUI (errore 0xE08010050005)
Summary: La modifica dell'autenticazione LDAP del server NAS da semplice a Kerberos potrebbe non riuscire con errore 0xE08010050005 quando il server SMB non è configurato.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Passaggi scenario:
1. Creazione di un server NAS con solo NFS abilitato.
2. Ldap configurato con autenticazione semplice sul server NFS creato in precedenza.
2. Creazione di Kerberos standalone sul server NFS.
3. Si è tentato di modificare l'autenticazione da semplice a Kerberos, la modifica non è riuscita con un messaggio di errore: Modifica del file LDAP non riuscita a causa di [ è necessario un server SMB aggiunto a un dominio per completare questa operazione]

1. Creazione di un server NAS con solo NFS abilitato.
2. Ldap configurato con autenticazione semplice sul server NFS creato in precedenza.
2. Creazione di Kerberos standalone sul server NFS.
3. Si è tentato di modificare l'autenticazione da semplice a Kerberos, la modifica non è riuscita con un messaggio di errore: Modifica del file LDAP non riuscita a causa di [ è necessario un server SMB aggiunto a un dominio per completare questa operazione]

Cause
Quando i dettagli del server SMB non sono configurati e l'utente tenta di modificare LDAP da semplice a Kerberos, l'aggiornamento avrà esito negativo a causa di un problema software in questa transizione.
Resolution
Creare il server SMB tramite API REST.
curl -X POST "http://[ClusterIP]:3085/api/types/smbServer/instances" "Content-Type: application/json" -d "
{ \"nasServer\": \"string\", \"isStandalone\": true, \"computerName\": \"string\", \"domain\": \"string\", \"netbiosName\": \"string\", \"workgroup\": \"string\", \"description\": \"string\", \"localAdminPassword\": \"string\"}Affected Products
PowerStoreArticle Properties
Article Number: 000202157
Article Type: Solution
Last Modified: 10 Aug 2022
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.