PowerStore: Det gick inte att ändra autentiseringen från enkel till Kerberos via GUI (fel 0xE08010050005)
Summary: Ändring av LDAP-autentisering för NAS-servern från enkel till Kerberos kan misslyckas med fel 0xE08010050005 när SMB-servern inte är konfigurerad.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Scenariosteg:
1. Skapade en NAS-server med endast NFS aktiverat.
2. Konfigurerad LDAP med enkel autentisering på NFS-servern som skapats ovan.
2. Skapade fristående Kerberos på NFS-servern.
3. Ett försök gjordes att ändra autentiseringen från enkel till Kerberos, modifieringen misslyckades med ett felmeddelande: Ändring av fil-LDAP misslyckades på grund av [En domänansluten SMB-server behövs för att slutföra den här åtgärden]

1. Skapade en NAS-server med endast NFS aktiverat.
2. Konfigurerad LDAP med enkel autentisering på NFS-servern som skapats ovan.
2. Skapade fristående Kerberos på NFS-servern.
3. Ett försök gjordes att ändra autentiseringen från enkel till Kerberos, modifieringen misslyckades med ett felmeddelande: Ändring av fil-LDAP misslyckades på grund av [En domänansluten SMB-server behövs för att slutföra den här åtgärden]

Cause
När SMB-serverinformation inte har konfigurerats och användaren försöker ändra LDAP från enkel till Kerberos misslyckas uppdateringen på grund av programvaruproblem i den här övergången.
Resolution
Skapa SMB-servern via REST API.
curl -X POST "http://[ClusterIP]:3085/api/types/smbServer/instances" "Content-Type: application/json" -d "
{ \"nasServer\": \"string\", \"isStandalone\": true, \"computerName\": \"string\", \"domain\": \"string\", \"netbiosName\": \"string\", \"workgroup\": \"string\", \"description\": \"string\", \"localAdminPassword\": \"string\"}Affected Products
PowerStoreArticle Properties
Article Number: 000202157
Article Type: Solution
Last Modified: 10 Aug 2022
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.