Avamar Administrator не удается подключиться к неизвестному хосту из-за неправильных разрешений для файлов хостов Windows

Summary: Avamar Administrator не удается подключиться к неизвестному хосту из-за неправильных разрешений для файлов хостов Windows.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Среды:
Avamar Server v7.4.0-177 64-разрядная

Windows 7
При подключении к Avamar Administrator с помощью IP-адреса или полного имени хоста задача завершается сбоем.  

В этой ситуации мы полагаются на файл хостов Avamar, чтобы предоставить разрешение имен серверу Avamar.

Подключение по IP-адресу
При этом возвращается сообщение «Unknown host: <hostname> nested exception isj ava.net.UnknownhostException: <hostname> 



Подключение по IP-адресуConnecting by fully qualified hostname (FQDN)

This does not display an error message. FQDN возвращается красными буквами.
 
Подключение по полностью определенному имени хоста (fqdn)

Разрешение имен настроено для сервера Avamar в файле хостов Windows, например:
x.x.33.130 avmgen4t-single.domain.com avmge4t-single

На ПК Avamar Administrator можно выполнить команду ping на сервере Avamar по IP-адресу.

Однако попытка выполнить ping-запрос сервера Avamar с использованием имени хоста завершается сбоем, как если бы запись файла hosts для сервера Avamar игнорирулась.
C:\Users\USER>ping avmgen4t-single.domain.com
Ping request could not find host avmgen4t-single.domain.com. Please check the name and try again.

Это происходит даже в случае удаления файла hosts или хэширования содержимого с хэшированием # перед записью для Avamar.  

Когда пользователь подключается по IP-адресу, поскольку имя хоста возвращается в рамках ошибки, это означает, что имя хоста кэшируется где-то. или что он называется внешним DNS-сервером.

Это поведение сохраняется даже после очистки кэша DNS-сервера Windows
C:\Users\USER>ipconfig /flushdns
Windows IP Configuration
Successfully flushed the DNS Resolver Cache.



Cause

Возникла проблема с разрешениями для файлов хостов.


Resolution

Повторно создайте файл hosts с разрешениями по умолчанию. 

1. Создайте новый текстовый файл на рабочем столе.
2. Скопируйте и вставьте содержимое текущего файла hosts в этот файл в Блокноте.
3. Сохраните новый текстовый файл и переименуйте его на хостах.
4. Скопируйте (не перемещайте) файл в каталог %SystemRoot%\System32\drivers\etc . Перезапись старого файла. Перемещение файла не будет работать.

Additional Information

Рекомендации по поиску и устранению неисправностей, связанные с ситуациями, когда записи файлов хостов не распознаются, можно найти в следующей статье.
http://serverfault.com/questions/452268/hosts-file-ignored-how-to-troubleshoot

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000027539
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.