Avamar: Administrator fails to connect "Unknown host" due to Windows hosts file permissions

Summary: Avamar Administrator fails to connect with "Unknown host" due to incorrect Windows hosts file permissions.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Environment:
Avamar server v7.4.0-177
Windows 7 64 bit

When connecting to the Avamar Administrator using IP or fully qualified hostname, the task fails.  

In this situation we are relying on the Avamar hosts file to provide name resolution to the Avamar server.

Connecting by IP address
This returns "Unknown host: <hostname> nested exception is java.net.UnknownhostException: <hostname> 

Connecting by IP address

Connecting by fully qualified hostname (FQDN)

This does not display an error message. It returns the FQDN in red letters.
 
Connecting by fully qualified hostname (fqdn)

Name resolution is configured for the Avamar server in the Windows hosts file, for example:
x.x.33.130 avmgen4t-single.domain.com avmge4t-single

From the Avamar Administrator PC, it is possible to ping the Avamar server by IP.

However, attempting to ping the Avamar server using hostname fails as though the hosts file entry for the Avamar server were being ignored
C:\Users\USER>ping avmgen4t-single.domain.com
Ping request could not find host avmgen4t-single.domain.com. Please check the name and try again.

The same occurs, even if the hosts file is removed, or the contents hashed out with # preceding the entry for Avamar.  

When the user connects by IP, since the hostname is returned as part of the error this indicates that the hostname is cached somewhere. Or that it is called over an external DNS server.

The behavior persists even after flushing the Windows DNS cache
C:\Users\USER>ipconfig /flushdns
Windows IP Configuration
Successfully flushed the DNS Resolver Cache.



Cause

There is an issue with the hosts file permissions.


Resolution

Re-create the hosts file with default permissions. 

1. Create a new text file on your desktop.
2. Copy and paste the contents of your current hosts file into this file in Notepad.
3. Save the new text file and rename it to hosts.
4. Copy (do not move), the file to your %SystemRoot%\System32\drivers\etc directory. Overwrite the old file. Moving the file will not work.

Additional Information

Troubleshooting suggestions relating to situations where hosts file entries do not appear to be recognized can be found in the following article.
http://serverfault.com/questions/452268/hosts-file-ignored-how-to-troubleshoot

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000027539
Article Type: Solution
Last Modified: 05 Feb 2025
Version:  4
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