無法在 Unisphere for PowerMax 將資料傳送至 CloudIQ
Summary: 在使用 SRS GW 註冊 Unisphere for PowerMax (U4P) 後,客戶收到錯誤「Failed to process command: javax.ejb.EJBException Execution_Failed status 500」。
Symptoms
在 SRS GW 註冊嵌入式 U4P,並在 U4P 中選取「Send Data to CloudIQ」後,出現錯誤「Failed to process command: javax.ejb.EJBException Execution_Failed status 500」
當 root 使用者傳回陣列的兩個容器時,出現訊息指出「caller is not authorized the perform the requested operation」(例如 symaudit -sid XXXX list)。在兩個容器的 symauth 表格中,本機 SMC 使用者列為系統管理員,因此應具備必要的許可權。
smas.log
2022-10-19 22:02:48,712 警告 [em.bp.SECURITY] (預設 task-11) com.emc.em.domain.cirrus.CirrusEnrollment.isEnrollmentEnabled():Cirrus 註冊已停
用 2022-10-19 22:02:57,252 警告 [em.spa.SPA ] (主要) SpaQueryDefAccess.startTimer.JVM 0:false:false:false::0:0:0:0:0
2022-10-19 22:03: 00,681 警告 [em.bp.ESRS] (預設 task-35) com.emc.em.sage.esrs.ESRSCommandProcessor:變更 CloudIQ 資料收集詳細資料。
2022-10-19 22:03:01,005 警告 [em.bp.SECURITY] (預設任務-35) com.emc.em.domain.cirrus.CirrusEnrollment.enrollWithCirrus():嘗試透過使用者 XXXX 註冊 Cirrus CIQ_COLLECTION。註冊已停用。
2022-10-19 22:03:01,387 警告 [em.bp.UTIL] (預設任務-35) SymapiCallTracer:InputArgs::SymVnetContainerShow failed with code 3596 (The 指定的物件不存在)
symapi 記錄
10/24/2022 00:00:00.073 12309 26 EMC:UNIVMAX check_user_perms User Authorization Failure for User H:MGMT-0\smc, 群組,SID 000XXXXXXXXX -- 「VIEW」許可權不存在 (最低必要角色:Monitor)
10/24/2022 00:00:00.079 12309 26 EMC:UNIVMAX SymSfsMkdir Access Denied for User H:MGMT-0\smc, Group, access VIEW (最低必要角色:顯示器)
collection log
2022-10-03 14:42:23,214 INFO [em.bp.ESRS] (預設 task-55) com.emc.em.domain.esrs.sfs.SfsFileXFer.ctor:使用 S /CLOUDIQ_ESRS_FILES2 2022-10-03 14:42:23,243 警告 [em.bp.ESRS] (預設 task-55) 的 FS 目錄無法在陣列 000XXXXXXXXX 上建立目錄/CLOUDIQ_ESRS_FILES2:呼叫者無權執行要求的作業:重複層級錯誤的 Exception java.io.IOException:1584257354 2022-10-03 14:42:58,345 ERROR [em.bp.ESRS] (EE-ManagedScheduledExecutorService-collector-manager-Thread-29) CoNtextualEsrsService.init:Unable to process registration for array 000XXXXXXXXXXX: java.io.IOException:無法在陣列 000XXXXXXXXX 上建立目錄/CLOUDIQ_ESRS_FILES2:來電者無權執行所要求的作業
Cause
有許可權問題,妨礙建立用於檔案傳輸的 /CLOUDIQ_ESRS_FILES2 目錄。 這會在 Unisphere for PowerMax 中啟用將資料傳送至 CloudIQ 後,無法傳送資料。
Resolution
客戶已在 Unisphere 中勾選 Unisphere 360 支援核取方塊,並使用 SRS GW 取消註冊 U4P,僅需 1 小時的時間,並在 SRS GW 上重新註冊 U4P 且已連線,而且在勾選將資料傳送至 CloudIQ 的核取方塊時沒有發生任何錯誤。
總而言之,解決問題的步驟是:
1。在 Unisphere 中,移至「Settings > Preferences 」> 一般 >檢查 Unisphere 360 支援。
2.移至 「Settings > 管理 > Secure Remote Services 」,然後使用 SRS GW 取消註冊 Unisphere。
3.等待 1 小時。
4.移至 「設定 > 管理 > 安全遠端服務 」,然後使用 SRS GW 重新註冊 U4P。
5.移至 「Settings > 管理 > CloudIQ 」,然後勾選「將資料傳送至 CloudIQ」的本機系統核取方塊。