Não é possível enviar dados para o CloudIQ no Unisphere for PowerMax

Summary: O cliente está recebendo um erro "Failed to process command: javax.ejb.EJBException Execution_Failed status 500" após a caixa de seleção para enviar dados ao CloudIQ após o registro do Unisphere for PowerMax (U4P) com o SRS GW. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Depois de registrar o U4P incorporado com o SRS GW e selecionar Send Data to CloudIQ in U4P, um erro aparece "Failed to process command: javax.ejb.EJBException Execution_Failed status 500"

Quando discado em ambos os contêineres no array como usuário root, alguns comandos retornam com uma mensagem informando "caller is not authorized the perform the requested operation" (por exemplo, symaudit -sid XXXX list). O usuário local do SMC é listado como Admin na tabela symauth em ambos os contêineres, portanto, ele deve ter as permissões necessárias.


smas.log
2022-10-19 22:02:48,712 WARN [em.bp.SECURITY] (tarefa padrão-11) com.emc.em.domain.cirrus.CirrusEnrollment.isEnrollmentEnabled():a inscrição do Cirrus
está desativada em 2022-10-19 22:02:57.252 WARN [em.spa.SPA] (mestre) SpaQueryDefAccess.startTimer.JVM 0:false:false:false::::0:0:0
2022-10-19 22:0 3:00,681 WARN [em.bp.ESRS] (tarefa padrão-35) com.emc.em.insira.esrs.ESRSCommandProcessor:Alterando detalhes da coleta de dados do CloudIQ.
2022-10-19 22:03:01.005 WARN [em.bp.SECURITY] (tarefa padrão-35) com.emc.em.domain.cirrus.CirrusEnrollment.enrollWithCirrus(): tente se inscrever no Cirrus CIQ_COLLECTION pelo usuário XXXX. A inscrição está desabilitada.
2022-10-19 22:03:01,387 WARN [em.bp.UTIL] (tarefa padrão-35) SymapiCallTracer:InputArgs::SymVnetContainerShow failed with code 3596 (The objeto
especificado não existe)


symapi log
24/10/2022 00:00:00.073 12309 26 EMC:UNIVMAX check_user_perms User Authorization Failure for User H:MGMT-0\smc, Group , SID 000XXXXXXXXX -- 'VIEW' rights not present (função mínima necessária: Monitor)
24/10/2022 00:00:00.079 12309 26 EMC:UNIVMAX SymSfsMkdir Access Denied for User H:MGMT-0\smc, Group, access VIEW (função mínima necessária: Monitor)



registro decoleta 2022-10-03 14:42:23.214 INFO [em.bp.ESRS] (tarefa padrão-55) com.emc.em.domain.esrs.sfs.SfsFileXFer.ctor:using S Diretório DOFS de /CLOUDIQ_ESRS_FILES2 2022-10-03 14:42:23.243 WARN [em.bp.ESRS] (tarefa padrão-55) Não é possível criar o diretório /CLOUDIQ_ESRS_FILES2 no array 000XXXXXXXXX: O chamador não está autorizado a executar a operação solicitada :Exception java.io.IOException of level ERROR repeated: 1584257354 2022-10-03 14:42:58,345 ERROR [em.bp.ESRS] (EE-ManagedScheduledExecutorService-collector-manager-Thread-29) ContextualEsrsService.init:Unable to process registration for array 000XXXXXXXXX: java.io.IOException: Não é possível criar o diretório /CLOUDIQ_ESRS_FILES2 no array 000XXXXXXXXX: O chamador não está autorizado a realizar a operação solicitada


Cause

Houve problemas de permissão que impediam a criação do diretório /CLOUDIQ_ESRS_FILES2, usado para transferência de arquivos.  Isso impedirá que os dados sejam enviados depois de habilitar Send Data to CloudIQ no Unisphere for PowerMax.

Resolution

O cliente verificou a caixa de seleção Unisphere 360 Support no Unisphere e o U4P não registrado com o SRS GW, esperou 1 hora, registrou novamente o U4P com o SRS GW e ele se conectou e não teve erros ao marcar a caixa Send Data to CloudIQ.

Em resumo, as etapas para resolver o problema foram:
1. No Unisphere, acesse Settings > Preferences > General > check Unisphere 360 Support.
2. Vá para Settings > Management > Secure Remote Services e cancele o registro do Unisphere com o SRS GW.
3. Aguarde 1 hora.
4. Vá para Settings > Management > Secure Remote Services e registre novamente o U4P no SRS GW.
5. Vá para Settings > Management > CloudIQ e marque a caixa de seleção Send data to CloudIQ for local systems.

Affected Products

CloudIQ, PowerMax 2000, Unisphere for PowerMax
Article Properties
Article Number: 000204792
Article Type: Solution
Last Modified: 23 Feb 2023
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.