PowerProtect: VM Unable to create snapshot. Protection job for virtual machine fails with error related to bus-sharing.

Summary: Virtual Machine (VM) Unable to create snapshot. Unable to create a non-quiesced snapshot after a retry attempt. The virtual machine is configured to use a device that prevents the snapshot operation: Device '' is a SCSI controller engaged in bus-sharing. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager protection job for virtual machine backup fails when a virtual machine has RDM disks. The protection plan has RDM disks excluded from backup.

The following error message is reported on time of failure:

Error : Backup has FAILED. Unable to create snapshot. Unable to create non-quiesced snapshot after a retry attempt. Virtual machine is configured to use a device that prevents the snapshot operation: Device '' is a SCSI controller engaged in bus-sharing. (500) VADP is used as the data mover for the backup.
When Transparent Snapshot Data Mover (TSDM) is selected as data mover for the asset, the backup job still runs with VMware vStorage API for Data Protection (VADP). 

Cause

VADP backups are not supported for virtual machines with shared SCSI controllers even if the backup policy only includes disks that are not shared.

In PowerProtect Data Manager version 19.13 and below, there is a code defect. This defect still takes RDM disks in consideration although they have been excluded from the backup. As a result, backup jobs ends up using VADP instead of TSDM.

Resolution

Upgrade PowerProtect Data Manager to version 19.14 or above, use TSDM as the data mover and exclude RDM disks. This allows backup of the non-shared disks.

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Article Properties
Article Number: 000222609
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.