Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products

USB Devices Connected to Dell Docks May Experience Issues After Updating the Dock Firmware

Summary: This article provides information about the recent firmware (FW) update v01.00.36 for WD19, WD22TB4, and HD22Q Series docks has been reported to cause issues with connected USB devices. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Dock WD19
  • Dell Dock - WD19S
  • Dell Performance Dock - WD19DC
  • Dell Performance Dock - WD19DCS
  • Dell Thunderbolt Dock - WD19TB
  • Dell Thunderbolt Dock - WD19TBS
  • Dell Thunderbolt Dock - WD22TB4
  • Dell Dual Charge Dock - HD22Q

A few customers have reported errors with USB devices plugged into their dock after installing dock FW v01.00.36. The devices were USB RSA token generators and fingerprint readers. It is possible that other USB devices may be affected, but there have been no confirmed cases.

Note: For information about a related issue with USB headsets, reference USB Audio Issues on Dell Docks After Updating Firmware.

Cause

The USB hub modification in dock FW Version A05 has a timing issue. This can cause a buffer overflow that sends four bytes of redundant data. Some devices lack the error handling to deal with this.

Resolution

Dell engineering is aware of this issue and has released a firmware update, download the Dell Dock Firmware Package from the product page of your Dell dock.

Dock Firmware
Dell Dual Charge Dock - HD22Q v01.00.23 or later
All other Docks v01.00.44 or later

Affected Products

Dell Dual Charge Dock HD22Q, Dell Dock WD19, Dell Performance Dock - WD19DC, Dell Performance Dock – WD19DCS, Dell Dock – WD19S, Dell Thunderbolt Dock - WD19TB, Dell Thunderbolt Dock – WD19TBS, Dell Thunderbolt Dock – WD22TB4
Article Properties
Article Number: 000224626
Article Type: Solution
Last Modified: 17 Apr 2025
Version:  10
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.