NVP vProxy: VM save set resurrection process is not progressing

Summary: A Virtual Machine (VM) save set which resides on a non-DDboost device is being resurrected (cloned) back to a data domain device for restore. The resurrection process is not progressing and no data is being cloned to the staging dd device. ...

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Symptoms

A Virtual Machine (VM) resurrection restore was initiated from the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI).

NOTE: A resurrection restore is an automatic process which occurs when the save set selected for restore resides on a non-Data Domain device (AFTD, Tape, CloudBoost). When selecting the source save set an option is provided to select a "staging" pool, where a Data Domain clone device is configured. The resurrection process clones the save set back to the DD staging pool, then initiates the restore.

The resurrection process has started but no data transfer is seen:

recover session

The NMC Alerts window shows "waiting for writable volume" on the staging pool selected. 

NMC Alerts

The staging pool has a device mounted:

image.png

Cause

There is a copy of the same save set already present on the staging device volume.

1. Confirm the SSID from the recovery session:

recover session

3. Use mminfo to confirm if the save set appears on the staging device:

mminfo -kot -q ssid=SSID

Example:

nve:~ # mminfo -kot -q ssid=2891939064
 volume        type   vm_name         date     time         size ssid      fl backup_size
AFTDVMClone.001 adv_file lnx-client01  06/04/24 16:45:43  104 GB 2891939064 cr 104 GB
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

This is by design. You cannot create multiple copies of the same save set in the same target location. The NetWorker VMware Integration Guide states: Ensure that your selected pool does not already contain copies for this backup. If the primary source exists and you recover from a clone using the same staging pool, the recovery may stop responding.

Resolution

Check the save set flag of the copy on the staging volume:

nve:~ # mminfo -kot -q volume=ddvestaging.001
 volume        type   vm_name         date     time         size ssid      fl backup_size
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

In some instances, the previous resurrection may have completed succesfully, but a nsrclone failure may have caused the save set to be marked aborted (ca) or suspect (s). This would cause the restore to fail, and the save set would not be eligible for restore. There are two options based on whether the copy is valid.

Valid Save Set on Staging Device.

1. From the Recover tab, right-click the recovery session and click Stop.
2. Start the recovery again, and select the save set which was cloned back to DD. It should show a copy in both "Data Domain Copies" and "Other Media Copies" columns:

Available save sets

3. Once on the Select Alternate Recovery Sources page, select the copy from the Data Domain clone device:

Data Domain clone device

4. Perform the restore.

Save Set is Not Valid:

If the save set is not valid; either aborted (ca) or suspect (s). You must delete the save set and restart the resurrection again.

1. Get the SSID and clone id of the save set which resides on the staging device.

mminfo -kot -q volume=VOLUME_NAME -r vmname,savetime,sumflags,ssid,cloneid
Example:
nve:~ # mminfo -kot -q volume=ddvestaging.001 -r vmname,savetime,sumflags,ssid,cloneid
 vm_name    date   fl ssid          clone id
lnx-client01 06/04/24 ca 2891939064 1718033764

2. Using both the ssid/cloneid. Delete the save set:

nsrmm -d -S SSID/CLONEID
Example:
nve:~ # nsrmm -d -S 2891939064/1718033764

The following clones will be deleted:
2891939064/1718033764

Continue? y
Processing the clone list.
Deleting clones.
CAUTION: It is important to specify both the SSID/CLONEID. If you specify only the SSID it can delete all copies of that save set from the mm, including the source.

3. Restart the resurrection restore, selecting the save set with only the "Other Media Copy." Select the staging pool and begin the restore. The save set is cloned to the staging pool and the restore process begins once the clone completes.

Additional Information

If you are observing an issue where the clone is either not completing or completing but does not appear to be valid. Remove the invalid aborted (ca) or suspect (s) save set as detailed above. Manually clone the save set using the nsrclone command and review the nsrclone output for more information:

nsrclone -vvv [{optional} -D[1-7]] -b STAGING_POOL_NAME -S SSID/CLONEID

Where SSID/CLONEID is the SSID and CloneId of the save set residing on the non-DD device. Output can be redirected to a file; optionally debugging can be added with -D levels 1 through 7

See: NVP vProxy: How to manually clone a VM save set from a non-Data Domain device to a Data Domain clone device?

Analysis of the target Data Domain's filesys report and ddfs.info log may be needed.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225923
Article Type: Solution
Last Modified: 22 May 2025
Version:  2
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