VxFlex:在 SDS 节点重新启动后,某些 CloudLink 加密的 SDS 设备标记为错误
Summary: VxFlex:在 SDS 节点重新启动后,某些 CloudLink 加密的 SDS 设备标记为错误
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Symptoms
SDS 重新启动后,某些 CloudLink 加密设备仍可正常工作,而其余设备则标记为 Error。
在已重新启动的 SDS 中标记为“错误”状态的多个 SDS 设备。这可能会导致容量减少,并可能导致更长的重建时间。
在 SDS trc 中:
21/06 13:09:34.917236 0x7fed52ebbeb0:mosAsyncIO_OpenFileEx:00376: WARNING: Failed to open IO file /dev/mapper/svm_sdg with rc 3 21/06 13:09:34.917238 0x7fed52ebbeb0:file_OpenEx:00707: Open error /dev/mapper/svm_sdg, NOT_FOUND 21/06 13:09:34.917241 0x7fed52ebbeb0:phyDev_ReadDevId:02649: failed to open file: path=/dev/mapper/svm_sdg, NOT_FOUND
SDS 的 cfg/partitions 文件包含一个或多个带有 mapper/svm_sd前缀的 SDS 设备的条目,以及一个或多个不带前缀的条目。
以下示例显示了这两种类型的条目。
8 96 1875374424 mapper/svm_sdg 8 112 1875374424 sdh The device errors can be cleared after the affected SDS has been restarted.
正在使用的 ScaleIO 版本高于 2.0.1.3,KB 000158993 不适用,但症状类似。
Cause
CloudLink 在磁盘检查方面存在问题,仅在启动 SDS 之前解锁某些设备。当 SDS 启动时, /dev/mapper/svm_sd* 尚未创建尚未解锁的磁盘的设备文件,因此会报告 SDS 设备错误。
Resolution
此问题已在 Cloud Link 6.8 中得到修复。请参阅支持矩阵,以确保环境仍受支持。
要从此问题中恢复,请手动重新启动 SDS 服务并清除受影响的 SDS 设备错误。
为防止出现此问题,请在 CloudLink 解锁所有磁盘后启动 SDS:
- 在关闭节点之前,请运行“/opt/emc/scaleio/sds/bin/delete_service.sh”;重新启动后,等待用作 SDS 设备的所有磁盘都已解锁(“SVM 状态”或 CloudLink Control Center 将显示),然后运行“/opt/emc/scaleio/sds/bin/create_service.sh”;或
- 编辑“/opt/emc/extra/pre_run.sh”,并在最后一行上方插入“sleep 30”(如果问题仍然存在,即 SDS 进程启动时并非所有设备都已解锁,请考虑将此数字调整得更高 30):
... sleep 30 echo pre_run returned...$(date) >> /var/log/svm-sds
Additional Information
提醒:上面的睡眠解决方法不在升级中(升级到 6.7,因为它尚不包括此问题的永久修复),可能需要再次应用。
这不是 ScaleIO 软件问题。此问题在 Cloud Link 6.6 和 6.7 中出现,并在 Cloud Link 6.8 中得到修复。
为了方便跟踪,请在所有版本中使用 #CCTFY25Q4 作为关键词。
Affected Products
PowerFlex Appliance, CloudLink, PowerFlex SoftwareArticle Properties
Article Number: 000067615
Article Type: Solution
Last Modified: 24 Nov 2025
Version: 6
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