NetWorker: RHEL Pacemaker 클러스터의 nws 리소스가 "nsrd NSR critical Can't start nsrd..."를 시작하지 못함

Summary: NetWorker는 Pacemaker를 사용하여 RedHat High Availability 클러스터에 구축됩니다. /nsr가 로컬이며 클러스터 관리자가 관리해야 한다는 NetWorker 서버(nsrd) 서비스가 시작되지 않습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • /nsr_share/nsr/logs/daemon.raw는 서비스 시작 중에 다음 오류를 기록합니다.
73248 01/31/2023 12:57:48 PM  5 5 0 926312256 966299 0 nwrhelnodef.emclab.local nsrd NSR critical Can't start nsrd because /nsr/res (/nsr) is local, and NetWorker is configured as a cluster server. Use cluster manager to check NetWorker service status.
144354 01/31/2023 12:57:48 PM  1 5 0 130900160 963225 0 nwrhelnodef.emclab.local nsrctld NSR notice Daemon nsrd terminated.
  • 노드는 다음과 같은 lcmap으로 클러스터 리소스를 볼 수 있습니다.
root@NWrhelNodeF:~# lcmap
type: NSR_CLU_TYPE;
clu_type: NSR_LC_TYPE;
interface version: 1.0;

type: NSR_CLU_VIRTHOST;
hostname: 192.168.25.28;
local: FALSE;
owned paths: /nsr_share;
  • lcmap 출력은 pcs 리소스 구성과 일치 합니다. pcs 리소스 구성
root@NWrhelNodeF:~# pcs resource config
 Group: NW_group
  Resource: fs (class=ocf provider=heartbeat type=Filesystem)
   Attributes: device=/dev/sdb1 directory=/nsr_share fstype=ext4
   Operations: monitor interval=20 timeout=300 (fs-monitor-interval-20)
               start interval=0s timeout=60s (fs-start-interval-0s)
               stop interval=0s timeout=60s (fs-stop-interval-0s)
  Resource: ip (class=ocf provider=heartbeat type=IPaddr)
   Attributes: cidr_netmask=24 ip=192.168.25.28 nic=ens192
   Operations: monitor interval=15 timeout=120 (ip-monitor-interval-15)
               start interval=0s timeout=20s (ip-start-interval-0s)
               stop interval=0s timeout=20s (ip-stop-interval-0s)
  Resource: nws (class=ocf provider=EMC_NetWorker type=Server)
   Meta Attrs: is-managed=true
   Operations: meta-data interval=0 timeout=10 (nws-meta-data-interval-0)
               migrate_from interval=0 timeout=120 (nws-migrate_from-interval-0)
               migrate_to interval=0 timeout=60 (nws-migrate_to-interval-0)
               monitor interval=100 timeout=1000 (nws-monitor-interval-100)
               start interval=0 timeout=300 (nws-start-interval-0)
               stop interval=0 timeout=300 (nws-stop-interval-0)

Cause

IP 주소가 NetWorker 클러스터 구성에서 사용되는 이름으로 해결되지 않습니다.
root@NWrhelNodeF:~# nslookup 192.168.25.28
** server can't find 28.25.168.192.in-addr.arpa: NXDOMAIN
IP는 /usr/lib/ocf/resource.d/EMC_NetWorker/Server 파일에서 NSR_SERVERHOST 값으로 확인되어야 합니다.
root@NWrhelNodeF:~# cat /usr/lib/ocf/resource.d/EMC_NetWorker/Server | grep SERVERHOST
                    echo "q" | nsradmin -s ${NSR_SERVERHOST} -i - > /dev/null 2>&1
                        echo "q" | nsradmin -s ${NSR_SERVERHOST} -i - > /dev/null 2>&1
NSR_SERVERHOST=NWrhelClusD.emclab.local
이 값은 /usr/sbin/networker.cluster 스크립트를 실행할 때 설정됩니다.

Resolution

VIP의 이름 확인(Name Resolution)을 수정합니다. DNS 구성에서 AD 관리자가 수정하거나 클러스터에 관련된 각 노드에 /etc/hosts 파일 항목을 사용하여 수정할 수 있습니다.
root@NWrhelNodeF:~# nslookup 192.168.25.28
28.25.168.192.in-addr.arpa      name = NWrhelClusD.emclab.local.

이름이 올바르게 해결되면 NetWorker 서비스를 시작할 수 있습니다.

root@NWrhelNodeF:~# pcs resource cleanup nws
Cleaned up fs on NWrhelNodeF.emclab.local
Cleaned up fs on NWrhelNodeE.emclab.local
Cleaned up ip on NWrhelNodeF.emclab.local
Cleaned up ip on NWrhelNodeE.emclab.local
Cleaned up nws on NWrhelNodeF.emclab.local
Cleaned up nws on NWrhelNodeE.emclab.local

root@NWrhelNodeF:~# pcs resource
  * Resource Group: NW_group:
    * fs        (ocf::heartbeat:Filesystem):     Started NWrhelNodeF.emclab.local
    * ip        (ocf::heartbeat:IPaddr):         Started NWrhelNodeF.emclab.local
    * nws       (ocf::EMC_NetWorker:Server):     Started NWrhelNodeF.emclab.local

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000208093
Article Type: Solution
Last Modified: 30 Apr 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.