NetWorker: nsrexecd Fails to Start After Client Hostname Change

Summary: The nsrexecd service fails to start after renaming a NetWorker client system. This occurs because the hostname stored in the NSRLA database no longer matches the system’s current hostname. ...

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Symptoms

  • Attempting to start the NetWorker Remote Exec (nsrexecd) service results in the following error:

    "The NetWorker Remote Exec Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Error message as seen in UI

  • The daemon.raw log (located at C:\Program Files\EMC NetWorker\nsr\logs\ on Windows or /nsr/logs/ on Linux) contains an entry similar to
RAP critical Attributes 'name' or 'my hostname' of the nsrla resource do not resolve to the machine's hostname 'clientname.domain.com'. To correct the error, it may be necessary to delete the NSRLA database.

Cause

The client system was renamed, but the NSRLA database still contains the previous hostname. This mismatch prevents the nsrexecd service from initializing correctly. 

Resolution

  1. Stop all NetWorker services on the client.
  2. Rename the NSRLA database directory:
    • Windows:
      Rename C:\Program Files\EMC NetWorker\nsr\res\nsrladb to nsrladb_old
    • Linux:
      Rename /nsr/res/nsrladb to nsrladb_old
  3. Restart the NetWorker services.
    A new NSRLA database is generated with the correct hostname.

Affected Products

NetWorker
Article Properties
Article Number: 000376266
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  2
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