Inspiron or Latitude Laptop with a Qualcomm Processor Does Not Detect USB Device Connected Through a Dock

Summary: This article provides information about the USB detection issue seen on a Dell Qualcomm laptop.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell Qualcomm laptop may not detect a USB device connected to a dock. The issue occurs after reboot or hibernation.

Affected Platforms:

  • Inspiron 14 5441
  • Inspiron 14 Plus 7441
  • Latitude 5455
  • Latitude 7455

Affected Dock:

  • Dell Dual Charge Dock HD22Q
  • Dell Thunderbolt Dock - WD19TBS
  • Dell Thunderbolt Dock - WD22TB4
  • Dell Universal Dock UD22

Cause

USB Hub does not handle termination off and on properly.

Resolution

Updating to the following versions of Qualcomm Chipset Driver on the computer resolves the issue.

  • Qualcomm Chipset Driver version 2.1.0.25 or later for Inspiron 14 Plus 7441 and Latitude 7455
  • Qualcomm Chipset Driver version 2.1.0.14 or later for Inspiron 14 5441 and Latitude 5455

To download and install the driver, reference How to Download and Install Dell Drivers.

Affected Products

Dell Dual Charge Dock HD22Q, Dell Universal Dock UD22, Dell Thunderbolt Dock – WD19TBS, Inspiron 14 5441, Inspiron 14 Plus 7441, Latitude 5455, Latitude 7455, Dell Thunderbolt Dock – WD22TB4
Article Properties
Article Number: 000226583
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  4
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