Dell Pro Docks Have Network Connectivity Issues

Summary: This article provides more information about Dell docks intermittently dropping Local Area Network (LAN) connection.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Pro Dock WD25
  • Dell Pro Smart DockSD25
  • Dell Pro Thunderbolt 4 Dock WD25TBT4
  • Dell Pro Thunderbolt 4 Smart Dock SD25TBT4

Users have reported that the LAN connection on the docking station is either non-functional or has intermittent connectivity issues.

Cause

The LAN driver for the docking station is not installed.

Resolution

Do not replace hardware for this issue.

Install the dock LAN driver:

  • For DELL Pro Dock (WD25) and Dell Pro Smart Dock (SD25) require installing a Realtek USB LAN driver from the Drivers & Downloads page of the dock that you are using.
  • For Dell Pro Thunderbolt 4 Smart Dock (SD25TB4) and Dell Pro Thunderbolt 4 Dock (WD25TB4) require installing both Intel PCIE LAN and RTK USB LAN driver from the Drivers & Downloads page of the dock that you are using.

Affected Products

Dell Pro Smart Dock SD25, Dell Pro Thunderbolt 4 Smart Dock SD25TB4, Dell Pro Dock WD25, Dell Pro Thunderbolt 4 Dock WD25TB4
Article Properties
Article Number: 000337068
Article Type: Solution
Last Modified: 15 Aug 2025
Version:  2
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