NVP-vProxy: VM recovery is marked as successful but the VM does not boot with the error: Missing Operating System
Summary: NetWorker VMware Protection (NVP) vProxy Virtual Machine (VM) restore completed successfully. The recovered VM does not boot with the error: Missing Operating System
Symptoms
The NetWorker VMware Protection (NVP) vProxy solution is used to perform VM backups. A VM is recovered using either the Instant Access, or Virtual Machine Recovery methods, the recovery is marked as successful.
However, when viewed in the VMware Infrastructure Client or vSphere Web Client, the VM is not using the expected storage amount. The recovered VM does not start when powered on and shows the following message in the VMware console window:
The same behavior can be seen if a Virtual Disk Recovery is performed. Although the VM the disk was recovered to may continue to operate, the recovered disk is corrupt and inaccessible.
Cause
The backup save set used for the recovery is incomplete due to corrupted Change Block Tracking (CBT) files for this VM. One or more bad Change Tracking (CTK) files were not removed when CBT was reset.
Resolution
The following VMware KB article describes how to reset Change Block tracking on a VM.
Resetting Changed Block Tracking for VMware vSphere virtual machines (2139574)
Additional Information
A similar issue may be observed if the vProxy VM was vMotioned by VMware Distributed Resource Scheduler (DRS) during the recovery session: NetWorker: Virtual Machine Restore Does Not Complete, and VM Disk is Removed or Restored as an Empty Drive
During a restore session, the VM's disks are attached to the vProxy VM until the recovery session completes. In this scenario, the vProxy VM is vMotioned during the recovery by VMware's DRS settings. When the vProxy VM is vMotioned, it takes over ownership of any of the disks attached to it. The vProxy VM contains more than two disks, the extra disks attached to the vProxy belong to the VM that is missing its disks post restore. This is expected behavior with VMware vMotion, the above KB describes how to assess and resolve this scenario.