NetWorker: Backups failing with "Host Address Mismatch" or "Server Rejected Credential"

Summary: NetWorker backups are failing with "Host Address Mismatch" errors or "server rejected credential." You also cannot browse the client's "client properties save sets" field in the NMC. This issue generally has to do with peering issues between the client and server but can be caused by incorrect information in the clients NSRLADB. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker backups are failing with "Host Address Mismatch" errors or "server rejected credential."
You also cannot browse the client's "client properties save sets" field in the NetWorker Management Console (NMC).

Cause

This issue generally has to do with peer information mismatch between the client and server but can be caused by incorrect information in the clients NSRLADB.

Resolution

Before proceeding with the next steps, ensure that all network connectivity is functioning as intended in your environment. 

  1. Review hosts files on the hosts involved and ensure that IP addresses and hostnames are specified correctly (if used).

Linux: /etc/hosts
Windows: C:\Windows\System32\drivers\etc\hosts

  1. Perform nslookup Fully Qualified Domain Name (FQDN), ShortName, and IP between the NetWorker server and clients. 
  2. Ensure that the required port communication is open between NetWorker server's, clients, and any storage nodes used in the process: NetWorker Processes and Ports


Clear the NetWorker Peer Information.

NetWorker: How to clear NSR peer information mismatches automatically using nsradmin -C

 Regenerate the Clients NSRLADB.

  1. On the NetWorker CLIENT, run the following commands:
C:\>nsradmin -p nsrexec
    nsradmin> p type: nsrla
Example:
nsrla resource name for a NetWorker client
Client resource configuration on NetWorker server.
NOTE: The name value on the client's NSRLADB should match the name the client was configured with in the NMC. The above examples exhibit a mismatch scenario. If the name does not match, proceed with the next steps. Peer information should already be deleted from both the NetWorker server and client before proceeding.
  1. On The NetWorker CLIENT, stop the client services by running the following command:
Linux: nsr_shutdown
Windows: net stop nsrexecd
  1. Once the service has stopped, create an OS hosts file entry on the client to reflect the clients IP and name that was used in the NMC
For example:
192.168.25.8          clusternode1.x.lab.emc.com          clusternode1
 
NOTE: The above exhibits the correct formatting required for the example provided in this KB. The client was added to NetWorker using its FQDN but the clients NSRLA was showing the shortname instead. To correct this, the first name alias used in the hosts file should be the FQDN. In your environment, ensure that the first name alias used is the same name used to configure the client on the NetWorker server.

Once the changes to the hosts file are made ensure that changes are saved.

  1. Go to the client's NetWorker installation directory and rename the NSRLADB folder (Do not Delete it).

Linux: /nsr/res/nsrladb
Windows (Default): C:\Program Files\EMC NetWorker\nsr\res\nsrladb

  1. Start the NetWorker client service:

Linux: systemctl start networker
Windows: net start nsrexecd

  1. From nsradmin, validate that the clients NSRLADB resource shows the correct hostname.
C:\>nsradmin -p nsrexec
    nsradmin> p type: nsrla
client shows correct nsrla name
  1. Once the correct name is displayed in the clients NSRLADB, attempt to browse the client's save sets from the client properties or initiate a backup.

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000039013
Article Type: Solution
Last Modified: 15 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.