Dell EMC Unity: Rreplication connection setup failure : Failed to register the local system on the remote side

Summary: Impact - Replication for sync/async setup can fail to register a connection

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



An attempt was made to set up a synchronous replication connection failed with the following:

"Failed: Failed to register the local system on the remote side. One of the reasons could be authentication failure, please check local admin credentials passed in the request. (Error Code: 0x6500176)

Rollback result: task was rolled back and marked as failed. this is because some tasks failed or SP rebooted during task execution. (Error Code0x100a)"
--------------------------------------------------------------------------------------------

 Cli attempt for async setup in similar scenario:

   19:20:46 root@VIRT1647H6V9FZ-spa spa:/EMC/CEM/log> uemcli -user admin -securePassword /remote/sys create -addr 10.xx.xx.xxx -srcUsername admin -srcPasswordSecure  -dstUsername admin -dstPasswordSecure -connectionType async
   Password:
   Storage system address: 127.0.0.1
   Storage system port: 443
   HTTPS connection
  
   Remote certificate:
   Issuer:     CN=DRUNITY02
   Subject:    CN=DRUNITY02
   Valid from: 2016-11-21 17:24:10 Z
   Valid to:   2019-11-21 17:24:10 Z
   Serial:     00979668053e912f6c
   Id:         0611223671
  
   [Secure] Type the user password that is used to access the local system.
   Password:
......
   Operation failed. Error code: 0x6500159
   Cannot connect to remote system, please check the IP address used for creating connection and the user's authentication credentials. (Error Code:0x6500159)  


Cause

On one instance, 
It was found that the replication interfaces were configured on the Ethernet ports and not the Sync Replication Management Port.

The problem can be related on the basic of terms to time skew or wrong password provided in the connection setup, however this is not the case in this instance.

A previous connection attempt was already attempted previously between the two system and either deleted or never concluded properly.

Resolution

Perform a complete cleanup of both sides 
Steps required:

1. Delete the existing replication interfaces.(this assumes all connections already removed prior)
2. Restart the Management Software on both arrays
3. Check for any connections listed under Replication Connections, if there are any present delete them
4. Configure the Replication Interfaces using the async/sync Designated Replication Ports.
5. Create the Replication connection between the two management IP's
6. Replication can now be set up for the LUNs/Filesystems.

Additional Information

On one such instance:
While working through this Support found that after the replication interfaces were deleted and another attempt made to create a replication connection (as there were none listed), we saw the following error:
"A remote connection with this IP address already exists. Run a verify operation on the existing connection . {Error Code:0x89ba}"

At this point we restarted the management software, the connection was then listed on the primary array with a warning, Support selected the verify and update option and it failed with:
"Remote system validation failed. The time skew between the local and remote systems may be more than 10 minutes, or there is a network communication issue. {Error Code:0x899d}"
We deleted the connection and recreated it successfully.

On a similar incident,
A cleanup was completely performed on the destination system (VSA ,fully redeployed from OVF template) but the problem persisted.
After moving to true DR setup physical remote unity-system , and the problem still persisting, Source side cleanup was performed and SPA was also rebooted (and upgraded) which finally resolved the problem.

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family
Article Properties
Article Number: 000052091
Article Type: Solution
Last Modified: 13 Jun 2025
Version:  3
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