Avamar: Os backups do Data Domain estão falhando ao replicar com a mensagem "o usuário não tem direitos de acesso suficientes"

Summary: Avamar — os backups do Data Domain estão falhando ao replicar com a mensagem "o usuário não tem direitos de acesso suficientes".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Pode ter sido especificado um client que teria interrompido o acesso de todos os clients.

Os backups salvos em um Data Domain com integração ao Avamar não são replicados para fins de recuperação de desastres (DR).

Quando a replicação é executada, os backups armazenados no Avamar são replicados com sucesso, mas os backups armazenados no Data Domain falham quando o avtar tenta uma conexão com o DD de destino.

As seguintes mensagens são vistas nos logs de replicação que podem ser acessados no console do Avamar Administrator para cada trabalho com falha:

avtar Warning <18125>: Calling DDR_OPEN returned result code:5075 message:the user has insufficient access rights
avtar FATAL <10608>: Replication failed: could not open connection to dest DDR <target DDR hostname>, dest LSU: avamar-xxxxxxxxxx, handle: -1, DDR result code: 5075, desc: the user has insufficient access rights. 
avtar FATAL <40009>: DDR encountered errors.

 

Cause

A lista de acesso do DD Boost do DD de destino não está permitindo acesso do Avamar, do DD de origem ou de todos os clients.

 

Resolution

Adicione os nomes de host Avamar e DD de origem à lista de acesso. Em seguida, execute novamente a replicação para confirmar se não há mais problemas para fazer log-in no Data Domain.

sysadmin@datadomain-dst# ddboost access show
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients show' instead.
DD Boost access allowed from the following clients:
dev-test.corp.dell.com

sysadmin@datadomain-dst# ddboost access add clients avamar-src.corp.dell.com
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients add' instead.
avamar-src.corp.dell.com : Added

sysadmin@datadomain-dst# ddboost access add clients datadomain-src.corp.dell.com
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients add' instead.
datadomain-src.corp.dell.com : Added

sysadmin@datadomain-dst# ddboost access show
**   This command is deprecated and will be unavailable in future releases.
Use 'ddboost clients show' instead.
DD Boost access allowed from the following clients:
dev-test.corp.dell.com
avamar-src.corp.dell.com
datadomain-src.corp.dell.com

 

Os logs de replicação do Avamar devem mostrar o seguinte:

2015-06-09 14:55:08 avtar Info <40041>: - Establishing a connection to the Data Domain system with basic authentication (Connection mode: A:0 E:0).
2015-06-09 14:55:08 avtar Info <0000>: - Connected to:
Data Domain System: datadomain-src.corp.dell.com
Model:              DD4500
DDOS:               Data Domain OS 5.5.0.9-471508
Serial Number:      FXXXXXXXXXXXXX
          Capacity
Total:        140,454,501,285,888 (127.74 TB)
Available:     70,235,477,508,096 (63.879 TB)
Used:          70,219,023,777,792 (63.864 TB)
Used logical: 6,445,745,982,552,764 (5.7250 PB)
2015-06-09 14:55:08 avtar Info <0000>: Setting default storage unit to 'avamar-xxxxxxxxxx' for handle 1
2015-06-09 14:55:08 avtar Info <10543>: Data Domain login to datadomain-src.corp.dell.com successful
2015-06-09 14:55:08 avtar Info <18845>: Restore mode - No Data Domain read compression.
2015-06-09 14:55:08 avtar Info <0000>: GSAN connected via: IPv4, retrieved Data Domain IPv4 hostname = datadomain-dst.corp.dell.com
2015-06-09 14:55:08 avtar Info <10606>: Connecting to Data Domain Destination Server "datadomain-dst.corp.dell.com" (LSU: avamar-xxxxxxxxxx, User: "********")
2015-06-09 14:55:08 avtar Info <10540>: - Resolved Data Domain Server name "datadomain-dst.corp.dell.com" to the IP address "10.1.1.2"
2015-06-09 14:55:08 avtar Info <40041>: - Establishing a connection to the Data Domain system with basic authentication (Connection mode: A:0 E:0).
2015-06-09 14:55:08 avtar Info <0000>: - Connected to:
Data Domain System: datadomain-dst.corp.dell.com
Model:              DD4500
DDOS:               Data Domain OS 5.5.0.9-471508
Serial Number:      FXXXXXXXXXXXXX
          Capacity
Total:        141,259,219,402,752 (128.47 TB)
Available:    105,297,588,781,056 (95.768 TB)
Used:          35,961,630,621,696 (32.707 TB)
Used logical: 2,021,959,548,732,281 (1.7959 PB)

 

Isso também pode ser feito usando o DD System Manager:

  1. Selecione Data Management > DD Boost > Settings.
  2. Na seção Allowed Clients, clique em Create (+).
    A caixa de diálogo Add Allowed Client é exibida.
  3. Digite o nome do host do client.
    Pode ser um nome de domínio totalmente qualificado (por exemplo, host1.dell.com) ou um nome de host com um caractere-curinga (por exemplo, *.dell.com).
  4. Selecione Encryption Strength.
    As opções são None (sem criptografia), Medium (AES128-SHA1) ou High (AES256-SHA1).
  5. Selecione o modo de autenticação.
    As opções são One Way, Two Way ou Anonymous.
  6. Clique em OK.

 

Additional Information

Um erro semelhante pode ocorrer com as atividades de manutenção do Avamar (checkpoint, hfscheck, coleta de lixo). Se qualquer uma dessas atividades estiver falhando com o MSG_ERR_DDR_ERROR, e o log ddrmaint mostrar que "o usuário tem privilégio insuficiente". Consulte Avamar-Data Domain Integration: Falhas de manutenção devido à propriedade incorreta da mtree do Avamar no sistema Data Domain

 

Outras causas incluem uma senha incorreta ou tempo de espera excedido da senha. Os seguintes artigos de conhecimento contêm informações adicionais:
Avamar – Falha ao atualizar ou se conectar ao sistema Data Domain devido a um usuário DDBoost bloqueado.
A interface do usuário do Avamar Administrator informa o status incorreto do Data Domain devido à senha ddboost expirada.

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000055013
Article Type: Solution
Last Modified: 16 Jul 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.