AppSync: A 'request timed out' pop-up message is received after providing credentials to the SQL Server Connection Settings
Summary: AppSync: A 'request timed out' pop-up message is received after providing credentials to the SQL Server Connection Settings
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
If the ODBC driver on the SQL Server host is not functioning properly, a 'request timed out' pop-up message will appear in the AppSync GUI 10 minutes after configuring the SQL Server Connection Settings.
The AppSync Plugin logs on the SQL Server host show:
date/time INFO SQLINSTANCE SQL: Connecting to database SQLINSTANCE\DatabaseName.master
date/time INFO SQLINSTANCE SQL: impersonating Domain\User
date/time INFO SQLINSTANCE SQL: Allocating environment handle
date/time INFO SQLINSTANCE SQL: Setting environment handle's attributes
date/time INFO SQLINSTANCE SQL: Allocating first connection handle
date/time INFO SQLINSTANCE SQL: Connecting to the driver
date/time INFO SQLINSTANCE SQL: impersonating Domain\User
date/time INFO SQLINSTANCE SQL: Allocating environment handle
date/time INFO SQLINSTANCE SQL: Setting environment handle's attributes
date/time INFO SQLINSTANCE SQL: Allocating first connection handle
date/time INFO SQLINSTANCE SQL: Connecting to the driver
No error messages or return code is seen or received by the Plugin.
ODBC is is used by AppSync to connect to SQL Server.
ODBC is is used by AppSync to connect to SQL Server.
Cause
ODBC on the SQL Server host was not functioning properly.
When starting ODBC utility manually, it does not provide the ODBC Administrators dialog. Rather, a pop-up message appears that does not contain any information.
When starting ODBC utility manually, it does not provide the ODBC Administrators dialog. Rather, a pop-up message appears that does not contain any information.
Resolution
To determine if ODBC is functioning properly on the SQL Server host, navigate to Control Panel > System and Security > Administrative Tools and start the ODBC application and ensure it starts and provides the ODBC Administrators dialog.
In this specific instance, the ODBC Administrators dialog was not presented. Running the following command from DOS as an Administrator resolved this issue:
In this specific instance, the ODBC Administrators dialog was not presented. Running the following command from DOS as an Administrator resolved this issue:
sfc /scannow
Prior to running the command, contact your SQL Server or Windows Administrator to confirm it is safe to run the command.
Additional Information
Please note, the timeout period experienced in the AppSync GUI is not a timeout related to the SQL connect command.The timeout period for not having received a reply from the AppSync Plugin.
There is no specific timeout related to the actual SQL connect command.
There is no specific timeout related to the actual SQL connect command.
Affected Products
AppSyncProducts
AppSyncArticle Properties
Article Number: 000055073
Article Type: Solution
Last Modified: 19 Aug 2025
Version: 4
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