Symptoms
Nie można zebrać plików "supportsave" lub "configupload" za pomocą protokołu bezpiecznego kopiowania (SCP) i protokołu bezpiecznego transferu plików (SFTP).
Przed kontynuowaniem potwierdź następujące informacje:
1. Przełącznik jest w stanie pingować serwer SCP/SFTP.
2. Serwer SCP/SFTP jest również w stanie pingować przełącznik.
3. Brak zapory blokującej porty SCP lub SFTP.
4. Działa z FTP.
Może również wystąpić podczas uaktualniania z FOS 7.1.x do 7.4.x.
Przykład SCP:
switch:admin> configupload
Protokół (scp, ftp, sftp, lokalny) [ftp]: scp
Czy chcesz kontynuować z CRA (T/N) [N]: y
Nazwa serwera lub adres IP [host]: 10.0.0.1
Nazwa użytkownika [użytkownik]: ścieżka administratora
/nazwa pliku [<katalog> domowy/config.txt]: /configupload.scp
Sekcja (all|chassis|switch [all]): switch
utracił konfigurację połączeniaPrzesyłanie
niedozwolone (scp failed).
Zakończone
SFTP Przykład:
switch:admin> supportsave
To polecenie zbiera dane RASLOG, TRACE, supportShow, plik rdzenia, FFDC
, a następnie przesyła je do serwera FTP/SCP/SFTP lub urządzenia USB.
Operacja ta może potrwać kilka minut.
UWAGA: supportSave najpierw przeniesie istniejący plik zrzutu śledzenia, a następnie
automatycznie wygeneruje i przeniesie najnowszy plik. Po wykonaniu tego polecenia zostaną przesłane dwa pliki zrzutu
śledzenia.
Czy możesz kontynuować? (yes, y, no, n): [no] y
Adres IP lub nazwa hosta: 10.0.0.1
Nazwa użytkownika: admin
Hasło:
Protokół (ftp | scp | sftp): Zdalny katalog sftp
: /
Czy chcesz kontynuować z CRA (T/N) [N]: y
Zapisywanie informacji pomocy technicznej dla switch:switch, module:RAS...
....................................................................................Host zdalny: nie można połączyć się z hostem zdalnym.
SupportSave nie powiodło się.
Jeśli CRA (Challenge Response Authentication) zostało wybrane jako "NO" lub "N", a problem nadal występuje i/lub dostęp do konta root nie jest dostępny, postępuj zgodnie z rozwiązaniem 2.
Cause
Plik known_hosts ma nieprawidłowy klucz publiczny, który uniemożliwia uwierzytelnianie wychodzące na serwerze scp/sftp.
Zwykle dzieje się tak, jeśli serwer musiał zostać odbudowany, a tym samym zmieniły się informacje o "kluczu" i w związku z tym za każdym razem, gdy uruchamiany jest supportsave, "klucz" wysyłany z przełącznika różni się od tego, który jest podany na serwerze, powodując '
Connection failed'
Komunikat.
Resolution
Aby rozwiązać ten problem, konieczny będzie dostęp do przełącznika z poziomu użytkownika root w celu usunięcia hosta z wpisu RSA przełącznika w pliku known_hosts. Gdy przełącznik nawiąże następne połączenie, zostanie wygenerowany nowy klucz RSA, który zostanie rozpropagowany do pliku known_hosts, aby umożliwić dostęp do zakończenia zbierania danych.
Wykonaj następujące czynności:
Rozwiązanie 1:
- Zaloguj się do przełącznika jako "root"
- Wprowadź następujące polecenie, aby usunąć publiczny klucz RSA serwera scp/sftp:
ssh-keygen -R XXX.XXX.XXX.XXX (gdzie XXX.XXX.XXX.XXX oznacza adres IP serwera scp/sftp
Rozwiązanie 2:
1. Zaloguj się do przełącznika jako "admin"
2. Usuń adres IP SFTP/SCP z listy znanych hostów:
># sshutil delknownhost
Przełącznik wyświetli monit o wprowadzenie adresu IP serwera SFTP, którego wpis należy usunąć.
Adres IP / nazwa hosta do usunięcia: <Adres IP serwera SFTP>
Następnie, po próbie supportsave lub configupload, adres IP hosta jest dodawany do listy known_host.