Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Connectrix B-Series:Неможливо зібрати ConfigUpload або Supportsave via SCP та SFTP

Summary: Не вдається зібрати supportsaves або configupload не вдається

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms



Неможливо зібрати дані "supportsaves" або "configupload" за допомогою Secure Copy (SCP) та Secure File Transfer Protocol (SFTP).

Будь ласка, підтвердьте наступне, перш ніж продовжити:

1. Комутатор може пінгувати сервер SCP/SFTP.
2. Сервер SCP/SFTP також може пінгувати перемикачами.
3. Немає брандмауера, який блокує порти SCP або SFTP.
4. Працює з FTP.

Також може виникати під час оновлення з FOS 7.1.x до 7.4.x.

Приклад SCP:
switch:admin> configupload
Protocol (scp, ftp, sftp, local) [ftp]: scp
Ви хочете продовжити з CRA (Y/N) [N]: y
Ім'я сервера або IP-адреса [хост]: 10.0.0.1
Ім'я користувача [user]: admin
Шлях/Ім'я файлу [<домашній каталог>/config.txt]: /configupload.scp
Розділ (всі|шасі|перемикач [всі]): перемикач
втрачено з'єднання
configUpload заборонено (scp не вдалося).
Припинений


SFTP Приклад:
switch:admin> supportsave
Ця команда збирає дані
RASLOG, TRACE, supportShow, основний файл, FFDC, а потім передає їх на сервер FTP/SCP/SFTP або пристрій USB.
Ця операція може тривати кілька хвилин.
ПРИМІТКА: supportSave спочатку передасть існуючий файл дампу трасування, а потім
автоматично згенерує та передасть останній. Після цієї команди буде передано два файли дампів
трасування.
Можна продовжити? (так, у, ні, н): [no] y

IP-адреса хоста або ім'я хоста: 10.0.0.1
Ім'я користувача: admin
Пароль:
Протокол (ftp | scp | sftp): sftp
Віддалений каталог: /

Ви хочете продовжити з CRA (Y/N) [N]: y
Збереження інформації про підтримку switch:switch, module:RAS...

....................................................................................Віддалений хост:Не вдалося підключитися до віддаленого хоста.
Помилка SupportSave.


Якщо CRA (Challenge Response Authentication) вибрано як «NO» або «N», а проблема все ще видима та/або root-доступ недоступний, дотримуйтесь рішення 2.

Cause

Файл known_hosts має неправильний відкритий ключ, який перешкоджає вихідній автентифікації за допомогою сервера scp/sftp. 
Зазвичай, це відбувається, якщо сервер потрібно перебудувати, і при цьому інформація про «ключ» змінилася, і тому кожного разу, коли виконується підтримка збереження, «ключ», надісланий з комутатора, відрізняється від того, що вказано на сервері, що спричиняє 'Помилка з'єднання' повідомлення. 
 

    Resolution

    Щоб виправити цю проблему, знадобиться root-доступ до комутатора, щоб видалити хост із запису RSA перемикачів у файлі known_hosts.  Коли комутатор здійснить наступне з'єднання, новий ключ RSA буде згенеровано та поширено у файл known_hosts, щоб надати доступ до завершення збору даних.

    Будь ласка, виконайте такі дії:
    Резолюція 1:

    1. Увійдіть до switch від імені "root"
    2. Введіть таку команду, щоб видалити публічний ключ RSA сервера scp/sftp:

      ssh-keygen -R XXX.XXX.XXX.XXX (де XXX.XXX.XXX.XXX — IP-адреса сервера scp/sftp
    Резолюція 2:
    1. Увійдіть у комутатор як "admin"
    2. Видаліть IP-адресу SFTP/SCP зі списку відомих хостів:
    ># sshutil delknownhost 
    Перемикач запропонує ввести IP-адресу SFTP-сервера, запис якого потрібно видалити.
    IP-адреса/ім'я хоста, яке потрібно видалити: <IP-адреса SFTP-сервера>

    Після цього, при спробі supportsave або configupload, IP-адреса хоста додається до списку known_host.

    Article Properties


    Last Published Date

    20 Nov 2020

    Version

    2

    Article Type

    Solution