Avamar - Data Domain 통합: MCS 및 Data Domain에서 토큰 캐시를 지우는 방법
Summary: Avamar - Data Domain 통합: MCS 및 Data Domain에서 토큰 캐시를 지우는 방법
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Avamar Administrator GUI에서 추출된 백업 로그에서 Data Domain으로의 Avamar 백업이 실패하는 동안 다음 오류가 표시될 수 있습니다.
avtar Warning <18125>: Calling DDR_OPEN_VIA_TOKEN returned result code:5341 message:SSL library error or avtar Error <41439>: Using invalid token:<token> avtar Error <10542>: Data Domain server "<ddhostname>" open failed DDR result code: 4904, desc: Invalid API argument.
Cause
MCS 또는 Data Domain의 토큰 캐시에 저장된 토큰이 오래되었을 수 있으며 지워야 합니다.
Resolution
이 프로세스는 MCS와 Data Domain 모두에서 토큰 캐싱을 지우며, 토큰 오류로 인해 발생하는 Avamar Client-Data Domain 연결 장애를 해결할 수 있습니다.
- Avamar에 대한 PuTTY 세션을 admin 사용자로 엽니다.
- Avamar에 있는 Data Domain 정보를 확인합니다. DD 호스트 이름 및 DDBoost 사용자 이름은 이 절차의 뒷부분에서 필요합니다.
ddrmaint read-ddr-info
- 시스템에서 실행 중인 유지 보수 작업(가비지 컬렉션, HFScheck 또는 체크포인트)이 없는지 확인합니다.
status.dpn
- 시스템을 양호한 제어 상태로 전환합니다.
dpnctl stop maint,sched
- Avamar에서 실행 중인 백업이 없고 Data Domain에서 실행 중인 ddboost 백업이 없는지 확인합니다.
avmaint sessions | grep sessionid
- Avamar에서 실행 중인 백업이 있는 경우 Avamar Administrator/AUI를 통해 또는 다음을 사용하여 명령줄에서 취소할 수 있습니다.
avmaint kill <sessionid>
- sysadmin 사용자로 Data Domain에 대한 PuTTY 세션을 열고 DDBoost를 사용하여 실행 중인 백업이 없는지 확인합니다.
ddboost streams show active all
- 실행 중인 bakcup이 없는 경우 Avamar Server에서 MCS 및 ddrmaint-service를 중지합니다.
dpnctl stop mcs,ddrmaint-service
- 그런 다음 Data Domain에 대한 putty 세션을 열고 Data Domain 명령줄에서 ddboost 사용자에 대한 token-access를 취소합니다. ddboost_username> 값은 <첫 번째 명령에서 이전에 가져와야 합니다
ddboost user revoke token-access <ddboost_username
- Data Domain 명령줄에서 ddboost 서비스를 중지하고 시작합니다.
ddboost disable ddboost enable
- Avamar putty 세션을 열고 Avamar 서비스를 시작합니다.
dpnctl start mcs,sched,maint,ddrmaint-service
- Avamar 명령줄에서 MCS의 Data Domain 구성을 업데이트합니다. dd_hostname> 값은 <첫 번째 명령에서 이전에 가져와야 합니다
mccli dd edit --name=<dd_hostname>
- 테스트 백업을 수행하여 제대로 실행될 수 있는지 확인합니다
- 토큰 캐시를 지운 후에도 언급된 오류로 인해 백업이 계속 실패하는 경우 Avamar 지원에 새 서비스 요청을 열어 이 문제를 추가로 해결하십시오.
Affected Products
AvamarProducts
Avamar, Data Domain, Integrated Data Protection Appliance FamilyArticle Properties
Article Number: 000056240
Article Type: Solution
Last Modified: 24 Aug 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.